Bug 857477 - wrong version of strigi-libs after upgrading to F17 from F16 via preupgrade
wrong version of strigi-libs after upgrading to F17 from F16 via preupgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 10:30 EDT by nexus6roybatty
Modified: 2012-09-14 11:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 11:39:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nexus6roybatty 2012-09-14 10:30:42 EDT
Description of problem:

there appears to be some version incompatibility between Exiv & Strigi libs.  it does not affect KDE performance or usability per se but it is probably creating some unnecessary dependencies for yum/RPM and/or making proper upgrade paths for these packages impossible.

please Note this is after upgrading a fedora 16 system to F17 via preupgrade


see below for my version(s) of Exiv libs
--------------------------------------------
 exiv2-libs                           x86_64 0.22-6.fc17          @anaconda-0  3.0 M
 libkexiv2                            x86_64 4.9.1-1.fc17         @kde-testing 1.5 M

---------------------------------------------------

root@localhost ~# yum check
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, tidy-cache
strigi-libs-0.7.7-5.20120626.fc16.x86_64 has missing requires of libexiv2.so.10()(64bit)
Error: check all
root@localhost ~# uname -a
Linux localhost.localdomain 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug 29 18:46:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
root@localhost ~#
Comment 1 nexus6roybatty 2012-09-14 10:46:06 EDT
could the problem simply be that there is not yet an F17-branded version of strigi-libs in the repos yet ?   maybe the fc16 release is the only one out there right now ?
Comment 2 Rex Dieter 2012-09-14 10:53:28 EDT
$ koji latest-pkg f17-updates strigi
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
strigi-0.7.7-3.fc17                       f17                   ausil

[rdieter1@localhost Downloads]$ koji latest-pkg f17-updates-testing strigi
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
strigi-0.7.7-5.20120626.fc17              f17-updates-testing   rdieter

sounds like you had kde-testing enabled on f16,  but neither kde-testing or updates-testing  on  f17 (yet).

Looks like getting this will fix it for you,
https://admin.fedoraproject.org/updates/FEDORA-2012-13344/strigi-0.7.7-5.20120626.fc17

(currently queue'd for stable updates)
Comment 3 Kevin Kofler 2012-09-14 11:39:27 EDT
So no upgrade path issue there, all the expected ordering requirements are satisfied:
f16 <= f16-updates <= f16-updates-testing
f17 <= f17-updates <= f17-updates-testing
f16 <= f17
f16-updates <= f17-updates
f16-updates-testing <= f17-updates-testing

Note You need to log in before you can comment on or make changes to this bug.