Bug 857479 - brp-java-repack-jars does not run in mock environments because zip is not present
brp-java-repack-jars does not run in mock environments because zip is not pre...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 10:35 EDT by Ade Lee
Modified: 2012-11-09 06:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-09 06:51:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Lee 2012-09-14 10:35:38 EDT
Description of problem:

The code in brp-java-repack-jars does not execute because the mock environment does not contain zip.  It does in fact contain unzip.  This is with a standard mock x86_64 f17 environment.

Not sure if this is the right component for this bug.  Should redhat-rpm-config require zip?  Please clone elsewhere - mock?, baseOS?  if needed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Package an rpm that contains jars within a mock environment.

2.  The build logs indicate that brp-java-repack-jars was run, but the timestamps in the jars are not reset.  You can also confirm that zip is not present.

  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2012-10-03 21:06:50 EDT
redhat-rpm-config-9.1.0-34.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/redhat-rpm-config-9.1.0-34.fc18
Comment 2 Fedora Update System 2012-10-04 13:48:34 EDT
Package redhat-rpm-config-9.1.0-34.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redhat-rpm-config-9.1.0-34.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15361/redhat-rpm-config-9.1.0-34.fc18
then log in and leave karma (feedback).
Comment 3 Toshio Ernie Kuratomi 2012-11-09 06:51:35 EST
This has been pushed to F18 stable.

Note You need to log in before you can comment on or make changes to this bug.