Bug 857503 - gluster volume heal $volname info sporadically reports nothing to heal
gluster volume heal $volname info sporadically reports nothing to heal
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: vsomyaju
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 12:03 EDT by Rob.Hendelman
Modified: 2015-03-04 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:53:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob.Hendelman 2012-09-14 12:03:45 EDT
Description of problem:
Sometimes gluster volume heal $volname info returns 0 when there are files to heal

Version-Release number of selected component (if applicable):
3.3.0 from git-master a032de191ec32be363d1feedfbd839f6dbde2579

How reproducible:
Rsync to gluster share, stop one server check heal info 

Steps to Reproduce:
1. Setup replica between two nodes
2. mount on client
3. rsync filesystem on client (in my case, nfs vers4) to the gluster mount
4. While rsyncing, stop one gluster services on ONE node ONLY with /etc/init.d/glusterd stop && pkill glusterd && pkill glusterfsd
5. On the node that is still up, run gluster heal volume $volname info several times in a row
  
Actual results:
Sometimes a long list of files to heal is returned.  Sometimes it says there are no files to heal.

Expected results:
Always should show an accurate list of files

Additional info:
Ubuntu 11.04 servers on 10GB e, 2 bricks each
Comment 1 Vijay Bellur 2012-10-11 20:56:35 EDT
CHANGE: http://review.gluster.org/4043 (cluster/afr: gluster volume heal $VN info sporadically reports nothing to heal) merged in master by Anand Avati (avati@redhat.com)
Comment 2 Rob.Hendelman 2012-11-08 13:04:40 EST
I tried building fresh servers & I can't get this condition to repeat.  Nice job!

Glad to see this fixed, however I did find a new/related issue (?)

if I run "volume heal data info" and gluster hasn't started outputting the results of this command I run the same command from another shell, I immediately get "operation failed" on the second shell.  If I repeat this after the first command starts returning data, the second one will work.

Timing issue?  Should I open a new bug report for this?

Note You need to log in before you can comment on or make changes to this bug.