This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 857530 - Document lvmetad in 6.4, if deemed necessary for users
Document lvmetad in 6.4, if deemed necessary for users
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Logical_Volume_Manager (Show other bugs)
6.0
All Linux
high Severity medium
: beta
: 6.3
Assigned To: Steven J. Levine
ecs-bugs
: Documentation, FutureFeature
Depends On: 464877
Blocks: 705085 464724 697866 718103 756082
  Show dependency treegraph
 
Reported: 2012-09-14 14:40 EDT by Steven J. Levine
Modified: 2013-02-25 13:30 EST (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 464877
Environment:
Last Closed: 2013-02-25 13:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 3 Steven J. Levine 2012-10-09 20:11:21 EDT
From me:

Ok, I'll try to follow up in a couple of weeks about the status of the command (re: tech. preview) and follow these guidelines for documentation if it is out of tech. preview for 6.4.

-Steven
Comment 6 Nenad Peric 2012-10-25 02:40:08 EDT
Passed basic LVM tests with lvmetad/use_lvmetad turned on. 

Verifying as SanityOnly. 

lvm2-libs-2.02.98-2.el6.x86_64
lvm2-2.02.98-2.el6.x86_64
lvm2-cluster-2.02.98-2.el6.x86_64

device-mapper-1.02.77-2.el6.x86_64
device-mapper-libs-1.02.77-2.el6.x86_64
device-mapper-event-1.02.77-2.el6.x86_64
device-mapper-event-libs-1.02.77-2.el6.x86_64

cmirror-2.02.98-2.el6.x86_64

kernel-firmware-2.6.32-330.el6.noarch
Comment 7 Steven J. Levine 2012-11-19 16:57:32 EST
I'm re-opening this bug, since it is a doc bug and I need to be sure that the documentation is correct (and verified).

Also the bug is assigned to me.  Since I didn't have the information for this feature until after the development period I'm exceptioning this bug.

I have a draft of what I have added to the LVM document that I will be sending to Petr for his ok.
Comment 10 Petr Rockai 2012-11-20 18:20:16 EST
I have drafted the following text, presumably would work as a new section, 3.6 Metadata Daemon:

LVM can optionally use a central metadata cache, implemented
through a daemon (lvmetad) and an udev rule. The metadata daemon
has two main purposes: it improves performance of LVM commands
and it allows udev to automatically activate logical volumes or
entire volume groups as they become available to the system.

To take advantage of the daemon, it needs to be started through
the "lvm2-lvmetad" service: use "chkconfig lvm2-lvmetad on" to
start the daemon automatically at boot time, and "service
lvm2-lvmetad start" to start it manually. Moreover, LVM needs to
be configured to make use of the daemon. To this effect, set the
lvm.conf variable "global/use_lvmetad" to 1.

Normally, each LVM command issues a disk scan to find all
relevant physical volumes and to read volume group
metadata. However, if the metadata daemon is running and enabled,
this expensive scan can be skipped: lvmetad scans each device
only once, when it becomes available, via udev rules. Especially
on systems with many disks, this can save significant amount of
I/O and reduce the time required to complete LVM operations.

When a new volume group is made available at runtime (eg. through
hotplug or iSCSI), its logical volumes must be activated in order
to be used. When lvmetad is enabled,
the "activation/auto_activation_volume_list" lvm.conf option can
be used to configure a list of volume groups and/or logical
volumes that should be automatically activated. Without lvmetad,
a manual activation is necessary.

Note You need to log in before you can comment on or make changes to this bug.