Bug 857580 - xfce - no menu borders
xfce - no menu borders
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard (Show other bugs)
18
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Cosimo Cecchi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Xfce
  Show dependency treegraph
 
Reported: 2012-09-14 19:37 EDT by Andy Lawrence
Modified: 2013-04-30 18:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnome-themes-standard-3.6.1-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-20 05:08:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of borderless menus (923.37 KB, image/jpeg)
2012-09-14 19:37 EDT, Andy Lawrence
no flags Details
better example (1.32 MB, image/jpeg)
2012-09-15 21:14 EDT, Andy Lawrence
no flags Details
menu after adwaita-gtk2-theme-3.6.1-3.fc18.x86_64.rpm update (29.06 KB, image/png)
2012-10-19 13:00 EDT, Tim Lauridsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 660271 None None None 2012-09-16 05:00:21 EDT

  None (edit)
Description Andy Lawrence 2012-09-14 19:37:25 EDT
Created attachment 613016 [details]
example of borderless menus

xfce desktop, panel menus have no menu borders.  This box is an upgrade from F17 xfce install.  Not only do the panel menus have no borders, menus in applications are also void of borders.  Windows themselves do have menus, doesn't appear related to the comment on the xfce wiki http://wiki.xfce.org/faq.

Please see the attached pict of an example.

xfce versions:

[andy@sandy linux]$ rpm -qa|grep xfce
libxfce4ui-4.10.0-2.fc18.x86_64
xfce4-diskperf-plugin-2.5.4-3.fc18.x86_64
xfce4-notifyd-0.2.2-5.fc18.x86_64
xfce4-fsguard-plugin-1.0.1-2.fc18.x86_64
xfce4-quicklauncher-plugin-1.9.4-14.fc18.x86_64
xfce4-timer-plugin-0.6.1-12.fc18.x86_64
xfce4-settings-4.10.0-2.fc18.x86_64
xfce4-panel-4.10.0-2.fc18.x86_64
xfce4-places-plugin-1.4.0-2.fc18.x86_64
xfce4-time-out-plugin-1.0.1-3.fc18.x86_64
xfce4-systemload-plugin-1.1.1-2.fc18.x86_64
xfce4-weather-plugin-0.8.1-1.fc18.x86_64
imsettings-xfce-1.3.1-1.fc18.x86_64
xfce4-mount-plugin-0.6.3-2.fc18.x86_64
xfce4-websearch-plugin-0.1.1-0.18.20070428svn2704.fc18.x86_64
xfce4-xkb-plugin-0.5.4.1-6.fc18.x86_64
xfce4-cpugraph-plugin-1.0.5-2.fc18.x86_64
xfce4-cellmodem-plugin-0.0.5-10.fc18.x86_64
xfce4-power-manager-1.2.0-2.fc18.x86_64
xfce4-doc-4.8.3-6.fc17.noarch
xfce4-dict-plugin-0.6.0-9.fc18.x86_64
libxfce4util-4.10.0-2.fc18.x86_64
xfce4-smartbookmark-plugin-0.4.4-5.fc18.x86_64
xfce4-netload-plugin-1.2.0-1.fc18.x86_64
xfce4-session-4.10.0-2.fc18.x86_64
xfce4-datetime-plugin-0.6.1-12.fc18.x86_64
xfce4-verve-plugin-1.0.0-8.fc18.x86_64
xfce4-mailwatch-plugin-1.1.0-13.fc18.x86_64
xfce4-genmon-plugin-3.4.0-2.fc18.x86_64
im-chooser-xfce-1.6.0-3.fc18.x86_64
xfce4-screenshooter-plugin-1.8.0-7.fc18.x86_64
xfce4-battery-plugin-1.0.5-3.fc18.x86_64
xfce4-icon-theme-4.4.3-7.fc18.noarch
xfce4-screenshooter-1.8.0-7.fc18.x86_64
xfce4-notes-plugin-1.7.7-6.fc18.x86_64
xfce4-taskmanager-1.0.0-5.fc18.x86_64
xfce4-mixer-4.8.0-7.fc18.x86_64
xfce4-eyes-plugin-4.4.1-8.fc18.x86_64
xfce4-session-engines-4.10.0-2.fc18.x86_64
gtk-xfce-engine-3.0.0-2.fc18.x86_64
xfce4-dict-0.6.0-9.fc18.x86_64
xfce4-appfinder-4.10.0-2.fc18.x86_64
libxfcegui4-4.10.0-3.fc18.x86_64
xfce4-sensors-plugin-1.2.3-6.fc18.x86_64
xfce4-clipman-plugin-1.2.3-2.fc18.x86_64
[andy@sandy linux]$
Comment 1 Kevin Fenzi 2012-09-15 20:43:15 EDT
I'm not sure I understand the issue. The default theme doesn't have borders around menus like that. 

Perhaps you were using a different one in the past before the upgrade?
Comment 2 Andy Lawrence 2012-09-15 21:10:14 EDT
On all of my F17 boxes (6 total) the default xfce menus have a light outlined border around the menu boxes, looks like a single pixel in width.  On my F18 boxes there is no border, not even a single pixel outline of the menu box.  If you zoom in on the pict I attached you can kinda see it missing.

It would be much easier to see if screen print would work with the menu open!  I had to take that pict with my camera.
Comment 3 Andy Lawrence 2012-09-15 21:14:54 EDT
Created attachment 613365 [details]
better example

Kevin, see the new pict it's a better example.  This one shows a Thunar menu, notice on the left how the menu is lost in white background cause the menu border is missing.
Comment 4 Andy Lawrence 2012-09-15 21:22:37 EDT
Ok, I figured it out.  My appearance > Style was blank, no Style selected, on both of my F18 boxes.  I picked one and the menu borders came back.

So I guess the bug is for whatever reason a default Style was not selected on upgrade/installation.  Perhaps already fixed?
Comment 5 Christoph Wickert 2012-09-16 05:00:20 EDT
This is a problem with the Theme itself, not with Xfce. See https://bugzilla.gnome.org/show_bug.cgi?id=660271

There is nothing we can do here. The only thing I wonder is: Should we add the theme to the xfce-desktop group in comps or even a hard dependency on it?
Comment 6 Christoph Wickert 2012-10-17 13:54:21 EDT
The upstream bug was fixed in gnome-themes-standard 3.6.1, which was just built at http://koji.fedoraproject.org/koji/buildinfo?buildID=360757

I am letting this bug block the F18Xfce tracker so we can get this into F18 final. Not sure if we can do something for the other releases though.
Comment 7 Tim Lauridsen 2012-10-19 13:00:32 EDT
Created attachment 630158 [details]
menu after adwaita-gtk2-theme-3.6.1-3.fc18.x86_64.rpm update

Just updated to adwaita-gtk2-theme-3.6.1-3.fc18.x86_64 and it solves the issue
Comment 8 Christoph Wickert 2012-10-20 05:08:13 EDT
Yeah, I think we should leave it with that. Marcus is not really happy with the look and still complains in the upstream bug, but I think we should trust Cosimo, he is the developer and the artist.

Note You need to log in before you can comment on or make changes to this bug.