Bug 857590 - [Back] or [Continue] button missing on netinst for newly-plugged network cable
[Back] or [Continue] button missing on netinst for newly-plugged network cable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 22:20 EDT by John Reiser
Modified: 2012-09-18 12:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 12:52:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2012-09-14 22:20:21 EDT
Description of problem: "Network cable unplugged" is detected properly when booting netinst.iso.  Then plugging in the network cable is detected and displayed properly, too (along with DHCP assignment.)  But now you are stuck because there is no [Back] or [Continue] button, and <Escape> does get you out of the dialog, either.  Your only option is [Quit], which is exactly what you don't want, now that you have plugged in the cable and gotten the network going!


Version-Release number of selected component (if applicable):
anaconda-18.6.8 (Fedora 18-Alpha-RC3)

How reproducible: every time


Steps to Reproduce:
1. Unplug all network cables, turn off WiFi.
2. Boot DVD of netinst.iso
3. Advance past Language selection and accept your Fate.

  
Actual results: Dialog screen "We'll need network access to fetch information about your location ..." showing cable unplugged.  This is correct and OK so far.  Now, plug in a network cable on a network that is running a DHCP server.  In a few seconds you'll get a DHCP address, the screen will change to show the cable plugged in, and list the DHCP parameters.  But you cannot proceed because there is no [Back] or [Continue] button.  Instead your only option is [Quit].


Expected results: After plugging in the cable and recognizing the DHCP assignment, then a [Back] or [Continue] button should be enabled.


Additional info: Bug 854159 (with full install media) is similar, but problem with netinst.iso happens sooner and details differ.
Comment 1 John Reiser 2012-09-14 22:43:38 EDT
Aarrrgggghhhh!  This is another graphics problem: detected by using a different box and different video graphics card.  There is a [Continue] button, but it is not on screen because graphics is not drawn correctly.  The [Continue] button is so close to the lower right-hand corner, and 7 or 8 cm away from anything else, that no part of it is visible wjen graphics is off center to the right by 3 cm or so.

Note You need to log in before you can comment on or make changes to this bug.