Bug 857594 - [abrt] xfce4-panel-4.8.6-4.fc17: g_type_check_instance_cast: Process /usr/lib/xfce4/panel/wrapper was killed by signal 11 (SIGSEGV)
[abrt] xfce4-panel-4.8.6-4.fc17: g_type_check_instance_cast: Process /usr/lib...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:089c69c273d24cd6151f3d2f373...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 23:24 EDT by JW Hall
Modified: 2012-09-23 23:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 23:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (824 bytes, text/plain)
2012-09-14 23:24 EDT, JW Hall
no flags Details
File: environ (1.42 KB, text/plain)
2012-09-14 23:24 EDT, JW Hall
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-14 23:24 EDT, JW Hall
no flags Details
File: backtrace (16.83 KB, text/plain)
2012-09-14 23:24 EDT, JW Hall
no flags Details
File: cgroup (127 bytes, text/plain)
2012-09-14 23:24 EDT, JW Hall
no flags Details
File: smolt_data (2.97 KB, text/plain)
2012-09-14 23:24 EDT, JW Hall
no flags Details
File: xsession_errors (130.14 KB, text/plain)
2012-09-14 23:25 EDT, JW Hall
no flags Details
File: maps (21.24 KB, text/plain)
2012-09-14 23:25 EDT, JW Hall
no flags Details
File: dso_list (6.12 KB, text/plain)
2012-09-14 23:25 EDT, JW Hall
no flags Details
File: build_ids (2.60 KB, text/plain)
2012-09-14 23:25 EDT, JW Hall
no flags Details
File: var_log_messages (324 bytes, text/plain)
2012-09-14 23:25 EDT, JW Hall
no flags Details
File: open_fds (311 bytes, text/plain)
2012-09-14 23:25 EDT, JW Hall
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 9182 None None None 2012-09-18 18:23:37 EDT

  None (edit)
Description JW Hall 2012-09-14 23:24:45 EDT
Version-Release number of selected component:
xfce4-panel-4.8.6-4.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib/xfce4/panel/wrapper /usr/lib/xfce4/panel/plugins/libweather.so 22 18885651 weather 'Weather Update' 'Show current weather conditions' ''
crash_function: g_type_check_instance_cast
kernel:         3.5.2-3.fc17.i686

truncated backtrace:
:Thread no. 1 (7 frames)
: #0 g_type_check_instance_cast at gtype.c
: #1 auto_locate_cb at weather-config.c
: #2 cb_geolocation at weather-search.c
: #3 weather_http_receive_data_destroyed at weather-http.c
: #4 g_source_callback_unref at gmain.c
: #6 g_source_destroy_internal at gmain.c
: #11 gtk_main at gtkmain.c
Comment 1 JW Hall 2012-09-14 23:24:47 EDT
Created attachment 613043 [details]
File: core_backtrace
Comment 2 JW Hall 2012-09-14 23:24:49 EDT
Created attachment 613044 [details]
File: environ
Comment 3 JW Hall 2012-09-14 23:24:51 EDT
Created attachment 613045 [details]
File: limits
Comment 4 JW Hall 2012-09-14 23:24:53 EDT
Created attachment 613046 [details]
File: backtrace
Comment 5 JW Hall 2012-09-14 23:24:54 EDT
Created attachment 613047 [details]
File: cgroup
Comment 6 JW Hall 2012-09-14 23:24:56 EDT
Created attachment 613048 [details]
File: smolt_data
Comment 7 JW Hall 2012-09-14 23:25:02 EDT
Created attachment 613049 [details]
File: xsession_errors
Comment 8 JW Hall 2012-09-14 23:25:05 EDT
Created attachment 613050 [details]
File: maps
Comment 9 JW Hall 2012-09-14 23:25:07 EDT
Created attachment 613051 [details]
File: dso_list
Comment 10 JW Hall 2012-09-14 23:25:09 EDT
Created attachment 613052 [details]
File: build_ids
Comment 11 JW Hall 2012-09-14 23:25:10 EDT
Created attachment 613053 [details]
File: var_log_messages
Comment 12 JW Hall 2012-09-14 23:25:12 EDT
Created attachment 613054 [details]
File: open_fds
Comment 13 Kevin Fenzi 2012-09-15 20:41:05 EDT
This looks like a crash in the weather plugin. 

What version is installed?

rpm -q xfce4-weather-plugin

and what were you doing when it happened? Can you duplicate it?
Comment 14 JW Hall 2012-09-17 22:54:35 EDT
The system was booting up. I will get the weather app version when I get back to my pc.
Comment 15 JW Hall 2012-09-18 18:14:22 EDT
[buzz@hp-dv2000 ~]$ rpm -q xfce4-weather-plugin
xfce4-weather-plugin-0.8.1-1.fc17.i686
[buzz@hp-dv2000 ~]$
Comment 16 Christoph Wickert 2012-09-18 18:23:37 EDT
This is https://bugzilla.xfce.org/show_bug.cgi?id=9182 which was fixed in 0.8.2.
Comment 17 Fedora Update System 2012-09-18 18:26:31 EDT
xfce4-weather-plugin-0.8.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfce4-weather-plugin-0.8.2-1.fc18
Comment 18 Fedora Update System 2012-09-18 18:42:47 EDT
xfce4-weather-plugin-0.8.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xfce4-weather-plugin-0.8.2-1.fc17
Comment 19 Fedora Update System 2012-09-18 18:43:54 EDT
xfce4-weather-plugin-0.8.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xfce4-weather-plugin-0.8.2-1.fc16
Comment 20 Fedora Update System 2012-09-20 02:00:36 EDT
Package xfce4-weather-plugin-0.8.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-weather-plugin-0.8.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14416/xfce4-weather-plugin-0.8.2-1.fc18
then log in and leave karma (feedback).
Comment 21 JW Hall 2012-09-20 21:20:27 EDT
[root@hp-dv2000 buzz]# strace -s 1024 -o log /usr/bin/hddtemp -n -q /dev/sda
63
[root@hp-dv2000 buzz]#
Comment 22 JW Hall 2012-09-20 21:26:01 EDT
I was playing Monsterz. It was closed by the system and the error was posted in abrt to be reported. I guess reporting, even these types of errors, helps. I'm not exactly a unix pro, but I can do functions that you suggest or need from terminal, as long as you can give me the commands to perform.
Comment 23 JW Hall 2012-09-20 21:28:55 EDT
I played the game again with no problem, this time. It seems like it was a one time error, but then I'm definitely no software expert. I can only minimally function in software and command line.
Comment 24 Fedora Update System 2012-09-23 23:21:47 EDT
xfce4-weather-plugin-0.8.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.