Bug 857613 - 'make syntax-check' has disappeared in libguestfs 1.19
'make syntax-check' has disappeared in libguestfs 1.19
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 02:45 EDT by Richard W.M. Jones
Modified: 2012-09-15 04:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-15 04:35:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-09-15 02:45:57 EDT
Description of problem:

$ make syntax-check 
make: *** No rule to make target `syntax-check'.  Stop.

This rule still exists in libguestfs 1.18, so it seems to
have disappeared somewhere along the 1.19 development branch.

The very odd thing is that neither the 1.18 nor the git
Makefile* have any reference to 'syntax-check' at all.  I
cannot see how or where this rule is created, but I assume
it's something to do with gnulib.

Version-Release number of selected component (if applicable):

libguestfs 1.19.40 / git - doesn't work
libguestfs 1.18.7 - does work

How reproducible:

100%
Comment 1 Richard W.M. Jones 2012-09-15 02:46:28 EDT
CC'd to Jim because he added the rule originally.
Comment 2 Jim Meyering 2012-09-15 04:07:02 EDT
Hi Rich,

That rule is in the gnulib-provided maint.mk file,
which is included via GNUmakefile (also from gnulib),
and both are copied into your build directory via
gnulib-tool that is run from autogen's bootstrap invocation.

There is a mechanism (in bootstrap) to ensure that when you switch
 to a new gnulib commit, it reruns gnulib-tool, but that depends on
the stamp file, .git-module-status

You could find yourself in the "no syntax-check rule" situation
if you had somehow removed maint.mk and/or GNUmakefile without
also removing the stamp file, .git-module-status.

To recover, just remove the stamp file, .git-module-status,
and rerun ./autogen.sh.
Comment 3 Richard W.M. Jones 2012-09-15 04:35:41 EDT
Thanks Jim!  Fixed for me by removing .git-module-status and
rerunning autogen.  Not sure how it got out of synch ...

Note You need to log in before you can comment on or make changes to this bug.