Bug 857633 - Proxy settings don't work in Grip
Proxy settings don't work in Grip
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 06:31 EDT by David Waring
Modified: 2012-09-26 05:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:30:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix string pointers passed to curl_easy_setopt() and fix initialisation of user string. (890 bytes, patch)
2012-09-15 06:31 EDT, David Waring
no flags Details | Diff

  None (edit)
Description David Waring 2012-09-15 06:31:14 EDT
Created attachment 613230 [details]
Patch to fix string pointers passed to curl_easy_setopt() and fix initialisation of user string.

Description of problem:
The proxy settings don't work in Grip. This is due to Grip passing the wrong pointer to curl_easy_setopt().

Version-Release number of selected component (if applicable):
grip-3.2.0-33.fc17

How reproducible:
Always

Steps to Reproduce:
1. Start grip
2. Configure proxy settings
3. Observe via strace that DNS lookups are for garbled host names
  
Actual results:
Grip doesn't find disc info from cddb

Expected results:
Grip should retrieve disc info from cddb via configured proxy

Additional info:
Patch included to fix proxy string and also noticed user info was wrong too. Tested with local rebuild of RPM including this patch as patch9.
Comment 1 Fedora Update System 2012-09-15 15:15:26 EDT
grip-3.2.0-41.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/grip-3.2.0-41.fc18
Comment 2 Fedora Update System 2012-09-15 15:16:47 EDT
grip-3.2.0-41.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/grip-3.2.0-41.fc17
Comment 3 Adrian Reber 2012-09-15 15:18:33 EDT
Thanks for the bug report and the patch. Applied.
Comment 4 Fedora Update System 2012-09-16 15:16:54 EDT
Package grip-3.2.0-41.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grip-3.2.0-41.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13988/grip-3.2.0-41.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-20 16:30:46 EDT
grip-3.2.0-41.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-09-26 05:05:27 EDT
grip-3.2.0-41.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.