Bug 857658 - Cannot update to 1.7.0
Cannot update to 1.7.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcstar (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On: 960358
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 12:24 EDT by Fabien Archambault
Modified: 2013-08-23 20:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: gcstar-1.7.0-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 960358 (view as bug list)
Environment:
Last Closed: 2013-08-23 20:04:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabien Archambault 2012-09-15 12:24:40 EDT
Description of problem: I would like to get the version from updates-testing of gcstar but it fails updating due to a lack of dependencies.


Version-Release number of selected component (if applicable): gcstar-1.7.0-1.fc17.noarch


How reproducible: always


Steps to Reproduce:
1. yum clean all
2. yum update gcstar --enablerepo=updates-testing
  
Actual results:
Loaded plugins: auto-update-debuginfo, langpacks, presto
Resolving Dependencies
--> Running transaction check
---> Package gcstar.noarch 0:1.6.2-2.fc17 will be updated
---> Package gcstar.noarch 0:1.7.0-1.fc17 will be an update
--> Processing Dependency: perl(Gtk2::Table) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(Gtk2::HBox) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(Gtk2::Frame) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(Gtk2::EventBox) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCItemsLists::GCListOptions) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCItemsLists::GCImageListComponents) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCGraphicComponents::GCDoubleLists) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCGraphicComponents::GCBaseWidgets) for package: gcstar-1.7.0-1.fc17.noarch
--> Finished Dependency Resolution
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::EventBox)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::Frame)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCItemsLists::GCImageListComponents)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCGraphicComponents::GCBaseWidgets)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::Table)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCGraphicComponents::GCDoubleLists)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCItemsLists::GCListOptions)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::HBox)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:


Additional info:
Comment 1 Christian Jodar 2012-09-22 23:50:12 EDT
The problem seems to be with the provides detector (or however it's called) which finds what provides a given Perl package.

The current version of perl-Gtk2 package doesn't have some features in the "provides" list. However, I can perfectly use these features on my machine.

There should be a lot of classes here, only 34:

$ rpm -q --provides perl-Gtk2-1.241-2.fc17.x86_64 | wc -l
34

As an example, HBox should be listed here :

$ rpm -q --provides perl-Gtk2-1.241-2.fc17.x86_64 | grep Box
perl(Gtk2::VBox)  

But the feature is here, as suggested by the documentation in the same package:

$ rpm -q -l perl-Gtk2-1.241-2.fc17.x86_64 | grep Box
/usr/lib64/perl5/vendor_perl/Gtk2/Box.pod
/usr/lib64/perl5/vendor_perl/Gtk2/ButtonBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/ComboBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/ComboBoxEntry.pod
/usr/lib64/perl5/vendor_perl/Gtk2/EventBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/HBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/HButtonBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/HandleBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/VBox.pod
/usr/lib64/perl5/vendor_perl/Gtk2/VButtonBox.pod
/usr/share/man/man3/Gtk2::Box.3pm.gz
/usr/share/man/man3/Gtk2::ButtonBox.3pm.gz
/usr/share/man/man3/Gtk2::ComboBox.3pm.gz
/usr/share/man/man3/Gtk2::ComboBoxEntry.3pm.gz
/usr/share/man/man3/Gtk2::EventBox.3pm.gz
/usr/share/man/man3/Gtk2::HBox.3pm.gz
/usr/share/man/man3/Gtk2::HButtonBox.3pm.gz
/usr/share/man/man3/Gtk2::HandleBox.3pm.gz
/usr/share/man/man3/Gtk2::VBox.3pm.gz
/usr/share/man/man3/Gtk2::VButtonBox.3pm.gz


One can also notice here EventBox, which is also wrongly reported as missing.

I assign it to QA as it may be a know bug in the Fedora tools. It's for sure a regression (in the tool or in the perl-Gtk2 package) as this was working properly before.

I can also modify the GCstar package to explicitly list its own dependencies (the one starting with GC) as the same problem exist with them. But that wouldn't help until the problem with perl-Gtk2 is fixed.
Comment 2 Fabien Archambault 2012-10-12 09:56:11 EDT
Hi,
Is there any news about this bug?
Comment 3 Fabien Archambault 2012-10-30 13:38:52 EDT
up ?

# yum install gcstar --enablerepo=updates-testing
Loaded plugins: auto-update-debuginfo, langpacks, presto
Resolving Dependencies
--> Running transaction check
---> Package gcstar.noarch 0:1.6.2-2.fc17 will be updated
---> Package gcstar.noarch 0:1.7.0-1.fc17 will be an update
--> Processing Dependency: perl(Gtk2::Table) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(Gtk2::HBox) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(Gtk2::Frame) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(Gtk2::EventBox) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCItemsLists::GCListOptions) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCItemsLists::GCImageListComponents) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCGraphicComponents::GCDoubleLists) for package: gcstar-1.7.0-1.fc17.noarch
--> Processing Dependency: perl(GCGraphicComponents::GCBaseWidgets) for package: gcstar-1.7.0-1.fc17.noarch
--> Finished Dependency Resolution
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::EventBox)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::Frame)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCItemsLists::GCImageListComponents)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCGraphicComponents::GCBaseWidgets)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::Table)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCGraphicComponents::GCDoubleLists)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(GCItemsLists::GCListOptions)
Error: Package: gcstar-1.7.0-1.fc17.noarch (updates-testing)
           Requires: perl(Gtk2::HBox)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 4 Vaclav "sHINOBI" Misek 2012-12-02 11:49:06 EST
The bug persists also for F18.
Comment 5 Gerald Cox 2012-12-15 17:42:13 EST
Christian,

Should this bug be reassigned to whomever supports perl-Gtk2, the yum/rpm support group or both?

Looks like this bug has entered the land of the lost.  I see where it is waiting from a response from Tian, but not sure he'll be able to help if the issue is outside of his app....
Comment 6 Emmanuel Seyman 2013-05-07 02:00:35 EDT
Bug 960358 has been submitted against perl-Gtk2. Let's make this one about GCstar. I'm clearing needinfo, setting to F18 and making the two bugs related.

When installing from the F18 updates-testing repo, the following error are GCstar-related:

Error: Package: gcstar-1.7.0-1.fc18.noarch (updates-testing)
           Requires: perl(GCGraphicComponents::GCBaseWidgets)
Error: Package: gcstar-1.7.0-1.fc18.noarch (updates-testing)
           Requires: perl(GCGraphicComponents::GCDoubleLists)
Error: Package: gcstar-1.7.0-1.fc18.noarch (updates-testing)
           Requires: perl(GCItemsLists::GCImageListComponents)
Error: Package: gcstar-1.7.0-1.fc18.noarch (updates-testing)
           Requires: perl(GCItemsLists::GCListOptions)
Comment 7 Emmanuel Seyman 2013-05-12 06:09:22 EDT
The Perl-Gtk2 package in updates-testing fixes the Gtk problems. All that's left are the GCstar requirements and that appears to be fixed in Rawhide so backporting the package should be all that's required.

Christian, can you do this?
Comment 8 Fedora Update System 2013-08-14 15:56:58 EDT
gcstar-1.7.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gcstar-1.7.0-2.fc18
Comment 9 Emmanuel Seyman 2013-08-15 11:32:49 EDT
Folks, I'ld really appreciate some of you testing this update, just to make sure it does indeed work. Don't hésitate to add karma to bodhi if you can install it.
Comment 10 Fedora Update System 2013-08-15 19:31:01 EDT
Package gcstar-1.7.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcstar-1.7.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14849/gcstar-1.7.0-2.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-08-23 20:04:33 EDT
gcstar-1.7.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.