Bug 857662 - [mesa] libGL error: failed to open drm device
[mesa] libGL error: failed to open drm device
Status: CLOSED DUPLICATE of bug 806491
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 14:13 EDT by Joachim Frieben
Modified: 2012-09-25 18:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 18:08:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file (34.34 KB, text/plain)
2012-09-15 14:14 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2012-09-15 14:13:32 EDT
Description of problem:
Direct rendering is enabled on a ATI Radeon X800 SE (R430) (PCIE) video card as reported by Xorg.0.log ("RADEON(0): Direct rendering enabled"), but GL does not provide hardware acceleration:

$ LIBGL_DEBUG=verbose glxgears
libGL: OpenDriver: trying /usr/lib64/dri/r300_dri.so
libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: r300
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL: Can't open configuration file /home/fedora/.drirc: No such file or directory.

Version-Release number of selected component (if applicable):
mesa-libGL-8.1-0.21.fc18.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start X session.
2. Run 'LIBGL_DEBUG=verbose glxgears'.
  
Actual results:
GL falls back to using the "swrast" driver.

Expected results:
GL is using the "r300" driver.

Additional info:
- Issue has occurred intermittently during the F18 development cycle.
- Installed components include:
  * kernel-3.6.0-0.rc5.git2.1.fc18.x86_64
  * libdrm-2.4.39-1.fc18.x86_64
  * mesa-libGL-8.1-0.21.fc18.x86_64
  * xorg-x11-drv-ati-7.0.0-0.6.20120910git7c7f27756.fc18.x86_64
  * xorg-x11-server-Xorg-1.13.0-3.fc18.x86_64
Comment 1 Joachim Frieben 2012-09-15 14:14:32 EDT
Created attachment 613309 [details]
X log file
Comment 2 Adam Jackson 2012-09-21 13:45:11 EDT
How did you start X?
Comment 3 Kamil Páral 2012-09-25 07:27:05 EDT
I see the same problem nouveau Test Day:

$ LIBGL_DEBUG=verbose glxgears
libGL: OpenDriver: trying /usr/lib64/dri/nouveau_dri.so
libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: nouveau
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL: Can't open configuration file /home/kparal/.drirc: No such file or directory.

The desktop performance is *unusable*. glxinfo says I'm using llvmpipe, but it takes a second to refresh the screen for any action. Even typing it terminal is really hard.

I followed https://fedoraproject.org/wiki/QA:Testcase_nouveau_restartx :
I booted into runlevel 3 and executed "startx".
Comment 4 Adam Williamson 2012-09-25 18:08:19 EDT
this is therefore a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=806491 . We need to change the test case not to tell people to use startx.

*** This bug has been marked as a duplicate of bug 806491 ***

Note You need to log in before you can comment on or make changes to this bug.