Bug 857687 - engine: can't import a vm while its template is in image lock state
engine: can't import a vm while its template is in image lock state
Status: CLOSED DUPLICATE of bug 767617
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
Dafna Ron
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-16 04:16 EDT by Dafna Ron
Modified: 2016-02-10 11:39 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 04:30:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (17.51 KB, application/x-xz)
2012-09-16 04:16 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-16 04:16:50 EDT
Created attachment 613383 [details]
engine log

Description of problem:

trying to import a vm while its template is in image lock give a CanDoAction 
Error while executing action: Template's Image is locked (temporarily).

this means that I cannot import a vm to my setup if I am creating a vm using clone (this can sometimes take a long time - depending on the size of the disks and if I am using thin or preallocated copy). 

Version-Release number of selected component (if applicable):

si18

How reproducible:

100%

Steps to Reproduce:
1. import a template to your setup
2. create a vm with clone from the template
3. import a vm based on the template
  
Actual results:

we are failing with CanDoAction because the template image is locked

Expected results:

we should not fail since we are not reading from the template. 

Additional info: engine log

Note You need to log in before you can comment on or make changes to this bug.