Bug 857715 - [abrt] system-config-language-1.3.5-10.fc17: urllib.py:1204:unquote:AttributeError: 'NoneType' object has no attribute 'split'
[abrt] system-config-language-1.3.5-10.fc17: urllib.py:1204:unquote:Attribute...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
abrt_hash:e376ca2065f0d89b22cb1f208e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-16 09:14 EDT by sentike
Modified: 2013-01-31 03:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-31 03:57:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (36 bytes, text/plain)
2012-09-16 09:14 EDT, sentike
no flags Details

  None (edit)
Description sentike 2012-09-16 09:14:24 EDT
Version-Release number of selected component:
system-config-language-1.3.5-10.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/share/system-config-language/system-config-language.py
kernel:         3.3.4-5.fc17.x86_64

backtrace:
:urllib.py:1204:unquote:AttributeError: 'NoneType' object has no attribute 'split'
:
:Traceback (most recent call last):
:  File "/usr/share/system-config-language/language_gui.py", line 179, in okClicked
:    self.apply()
:  File "/usr/share/system-config-language/language_gui.py", line 295, in apply
:    install.install_language (self.mainWindow, grpid)
:  File "/usr/share/system-config-language/gui_install.py", line 423, in install_language
:    dlpkgs = self.downloadPackages(mainWindow)
:  File "/usr/share/system-config-language/gui_install.py", line 290, in downloadPackages
:    probs = self.downloadPkgs(dlpkgs)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2180, in downloadPkgs
:    self.plugins.run('predownload', pkglist=pkglist)
:  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
:    func(conduitcls(self, self.base, conf, **kwargs))
:  File "/usr/lib/yum-plugins/presto.py", line 633, in predownload_hook
:    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
:  File "/usr/lib/yum-plugins/presto.py", line 439, in downloadPkgs
:    cb.start(text=text, size=rebuild_size)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 127, in start
:    self._do_start(now)
:  File "/usr/share/system-config-language/gui_install.py", line 247, in _do_start
:    txt = _("Downloading %s") %(urllib2.unquote(self.basename),)
:  File "/usr/lib64/python2.7/urllib.py", line 1204, in unquote
:    res = s.split('%')
:AttributeError: 'NoneType' object has no attribute 'split'
:
:Local variables in innermost frame:
:s: None
Comment 1 sentike 2012-09-16 09:14:28 EDT
Created attachment 613409 [details]
File: event_log
Comment 2 Fedora Admin XMLRPC Client 2013-01-28 00:50:13 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Parag Nemade 2013-01-31 03:57:22 EST
Looks to me issue was with python-urlgrabber packages. I tried with current F17 build and it worked fine for me. You can try new update available system-config-language-1.3.5-11.fc17 also.

If you will find again this or any other issue then report a new bugzilla with complete information like what steps you did to find this bug so that I can reproduce it.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.