Bug 857856 - jacoco build failing in koji rawhide
jacoco build failing in koji rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: maven-plugin-tools (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 05:16 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 05:51:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch proposition (1010 bytes, patch)
2012-09-17 05:16 EDT, Krzysztof Daniel
no flags Details | Diff

  None (edit)
Description Krzysztof Daniel 2012-09-17 05:16:05 EDT
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:jar (attach-javadocs) on project jacoco-maven-plugin: MavenReportException: Error while creating archive: Unable to resolve artifact:groupId = 'org.apache.maven.plugin-tools'
[ERROR] artifactId = 'maven-plugin-tools-javadoc'
[ERROR] version = '2.8': Missing:
[ERROR] ----------
[ERROR] 1) org.easytesting:fest-assert:jar:1.4
[ERROR] 
[ERROR] Try downloading the file manually from the project website.
Comment 1 Krzysztof Daniel 2012-09-17 05:16:49 EDT
Created attachment 613596 [details]
Patch proposition

Adds missing BR/R.
Comment 2 Mikolaj Izdebski 2012-09-17 05:51:00 EDT
fest-assert is only a test dependency of maven-plugin-tools and as such it's not (and it won't be) included in Requires.

The problem is in the jococo package itself. jococo has a custom configuration for maven-javadoc-plugin and maven-javadoc-plugin is pulling in all test dependencies of all dependant artifacts.

The solution is to modify configuration of maven-javadoc-plugin or remove the plugin invocation entirely. I suggest adding somethink like that to jococo.spec:
  %pom_remove_plugin :maven-javadoc-plugin

Stanislav has another solution. Quoting him:
sochotni: kdaniel: http://maven.apache.org/plugins/maven-javadoc-plugin/examples/aggregate-dependency-sources.html
sochotni: kdaniel: try to exclude fest-assert with dependencySourceExcludes
sochotni: but generally you can probably remove the whole m-javadoc-p invocation, we generate javadocs separately
sochotni: worst case they won't be so nicely integrated
sochotni: but if you want to integrate them...I suggest adding BR for fest-assert (should help)

This is not a bug in maven-plugin-tools, so closing it now.

Note You need to log in before you can comment on or make changes to this bug.