Bug 857862 - pl2303: only root can use port
pl2303: only root can use port
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 05:46 EDT by The Source
Modified: 2013-03-13 11:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 11:50:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2012-09-17 05:46:42 EDT
Description of problem:
Despite all access rights were set properly for user for /dev/ttyUSB* nodes, user can not open them. It seems only root can. I checked access rights:
crw-rw---- 1 root dialout 188
The user is in dialout group and can perfectrly open ports with the same access rights but belonging to different modules. I also checked if port is used by someone else by fuser, it's not. Still I get "Device or resource busy" error every time I try to open port for r/w.
Also if I disconnect my convertor and reconnect it again, node name is changed (number is increased by 1).


Version-Release number of selected component (if applicable):
kernel-3.5.3-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 The Source 2012-09-17 05:57:21 EDT
Tested more. It seems the problem is deeper, because ftdi_sio devices are also affected.
Comment 2 Josh Boyer 2013-03-12 16:26:20 EDT
Are you still seeing this with 3.7.9 or 3.8.2 in updates-testing?
Comment 3 The Source 2013-03-13 11:50:40 EDT
No, after upgrading to F18 3.8.2 problem is gone.

Note You need to log in before you can comment on or make changes to this bug.