Bug 857886 - X crash when unlocking Gnome Shell
X crash when unlocking Gnome Shell
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-17 08:20 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 03:50:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (76.56 KB, text/x-log)
2012-09-17 08:20 EDT, Martin
no flags Details

  None (edit)
Description Martin 2012-09-17 08:20:53 EDT
Created attachment 613649 [details]
dmesg

Description of problem:
X crash when unlocking Gnome Shell.
I got a message in VT console after several seconds:
[drm] nouveau 0000:01:00.0: EvoCh 1 Mthd 0x0080 Data 0x00000000 (0x0006 0x05)

Version-Release number of selected component (if applicable):
gnome-shell-3.5.5-2.fc18.x86_64
kernel-3.6.0-0.rc2.git2.1.fc18.x86_64
xorg-x11-drv-nouveau-1.0.1-4.fc18.x86_64

01:00.0 VGA compatible controller: nVidia Corporation G98 [Quadro NVS 295] (rev a1)
Fedora 17 Alpha GOLD Desktop Live

How reproducible:
always

Steps to Reproduce:
1. boot live
2. lock Gnome Shell
3. try to unlock

Additional info:
see dmesg.log after crash - [ 4556.894154]
"systemctl restart gdm.service" brings me to GDM - [ 4951.505795]
[ 5128.889099] - after another GS unlock crash
[ 5140.385796] - another GDM restart
Comment 1 Kamil Páral 2012-09-17 09:11:49 EDT
I see something similar with Nvidia NVS 140M on my installed F18. Crash after unlocking the screensaver.

Dmesg says:
[ 4699.196057] [drm] nouveau 0000:01:00.0: EvoCh 1 Mthd 0x0080 Data 0x00000000 (0x0006 0x05)
[ 4705.203562] [drm] nouveau 0000:01:00.0: EvoCh 1 Mthd 0x0080 Data 0x00000000 (0x1006 0x05)
[ 4725.286870] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF IN
[ 4725.286875] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF 00320251 20369880 00000000 04000e00
[ 4725.286878] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP
[ 4725.286880] [drm] nouveau 0000:01:00.0: PGRAPH - ch 4 (0x0002a64000) subc 5 class 0x5039 mthd 0x023c data 0x00000000
[ 4725.286892] [drm] nouveau 0000:01:00.0: VM: trapped read at 0x0020556000 on ch 4 [0x00002a64] PGRAPH/DISPATCH/M2M_IN reason: PAGE_NOT_PRESENT
[ 4725.286899] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF IN
[ 4725.286903] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF 00320251 20369880 00000000 04000000
[ 4725.286905] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP
[ 4725.286907] [drm] nouveau 0000:01:00.0: PGRAPH - ch 4 (0x0002a64000) subc 5 class 0x5039 mthd 0x023c data 0x00000000
[ 4725.286916] [drm] nouveau 0000:01:00.0: VM: trapped read at 0x0000000000 on ch 4 [0x00002a64] PGRAPH/DISPATCH/M2M_IN reason: NULL_DMAOBJ
[ 4725.286923] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF IN
[ 4725.286927] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF 00320251 20369880 00000000 04000000
[ 4725.286929] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP
[ 4725.286930] [drm] nouveau 0000:01:00.0: PGRAPH - ch 4 (0x0002a64000) subc 5 class 0x5039 mthd 0x023c data 0x00000000
[ 4725.286940] [drm] nouveau 0000:01:00.0: VM: trapped read at 0x0000000000 on ch 4 [0x00002a64] PGRAPH/DISPATCH/M2M_IN reason: NULL_DMAOBJ
[ 4725.286946] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF IN
[ 4725.286950] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF 00320251 20369880 00000000 04000000
[ 4725.286952] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP
[ 4725.286953] [drm] nouveau 0000:01:00.0: PGRAPH - ch 4 (0x0002a64000) subc 5 class 0x5039 mthd 0x030c data 0x2055a000
[ 4725.286963] [drm] nouveau 0000:01:00.0: VM: trapped write at 0x0000000010 on ch 4 [0x00002a64] PGRAPH/DISPATCH/M2M_NOTIFY reason: NULL_DMAOBJ
[ 4725.286970] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF NOTIFY
[ 4725.286973] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP_M2MF 00304041 00000000 00000000 06000000
[ 4725.286975] [drm] nouveau 0000:01:00.0: PGRAPH - TRAP
[ 4725.286977] [drm] nouveau 0000:01:00.0: PGRAPH - ch 4 (0x0002a64000) subc 5 class 0x5039 mthd 0x0328 data 0x00000000
[ 4725.302603] [drm] nouveau 0000:01:00.0: EvoCh 1 Mthd 0x0080 Data 0x00000000 (0x1006 0x05)

Xotg.0.log.old says:
[ 10058.661] (EE) Backtrace:
[ 10058.663] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x46c266]
[ 10058.663] (EE) 1: /usr/bin/Xorg (0x400000+0x71a19) [0x471a19]
[ 10058.664] (EE) 2: /lib64/libpthread.so.0 (0x7fc56847d000+0xf000) [0x7fc56848c000]
[ 10058.664] (EE) 3: /lib64/libc.so.6 (0x7fc566ed0000+0x13cf60) [0x7fc56700cf60]
[ 10058.664] (EE) 4: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0x5a1e) [0x7fc565306a1e]
[ 10058.664] (EE) 5: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0x5ed3) [0x7fc565306ed3]
[ 10058.665] (EE) 6: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0x86da) [0x7fc5653096da]
[ 10058.665] (EE) 7: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0x127cb) [0x7fc5653137cb]
[ 10058.665] (EE) 8: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0xf20c) [0x7fc56531020c]
[ 10058.666] (EE) 9: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0xf597) [0x7fc565310597]
[ 10058.666] (EE) 10: /usr/bin/Xorg (0x400000+0x129e19) [0x529e19]
[ 10058.666] (EE) 11: /usr/lib64/xorg/modules/libexa.so (0x7fc565301000+0xccd9) [0x7fc56530dcd9]
[ 10058.667] (EE) 12: /usr/bin/Xorg (0x400000+0x12a0a1) [0x52a0a1]
[ 10058.667] (EE) 13: /usr/bin/Xorg (0x400000+0x1232b6) [0x5232b6]
[ 10058.668] (EE) 14: /usr/bin/Xorg (0x400000+0x395aa) [0x4395aa]
[ 10058.668] (EE) 15: /usr/bin/Xorg (0x400000+0x2805a) [0x42805a]
[ 10058.668] (EE) 16: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fc566ef1a05]
[ 10058.669] (EE) 17: /usr/bin/Xorg (0x400000+0x2839d) [0x42839d]
[ 10058.669] (EE) 
[ 10058.669] (EE) Segmentation fault at address 0x1d9

gnome-shell-3.5.5-2.fc18.x86_64
gdm-3.5.5-2.fc18.x86_64
kernel-3.6.0-0.rc5.git3.1.fc18.x86_64
xorg-x11-drv-nouveau-1.0.1-4.fc18.x86_64

Proposing as Beta blocker.
Comment 2 Adam Williamson 2012-09-26 14:03:33 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Accepted as a blocker per criterion "after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria must boot to a working graphical environment without unintended user intervention." - we're not really keen to start adding criteria for every possible case of 'perfectly normal desktop operation crashes X', we decided to simply affirm that a desktop which crashes on the unlock screen is not a 'working graphical environment'.

garretraziel suggests this may be fixed with latest packages, Martin and Kamil will re-test.
Comment 3 Kamil Páral 2012-10-03 03:50:58 EDT
Yes, this is now fixed.
gnome-shell-3.6.0-1
kernel-3.6.0-0.rc6.git0.2
xorg-x11-drv-nouveau-1.0.1-6

Note You need to log in before you can comment on or make changes to this bug.