Bug 857900 - please rename swift binary to swift-im
please rename swift binary to swift-im
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: swift (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 08:49 EDT by Pádraig Brady
Modified: 2016-01-04 09:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:21:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 674504 None None None 2012-09-17 09:56:13 EDT

  None (edit)
Description Pádraig Brady 2012-09-17 08:49:48 EDT
The swift name conflicts with the binary in python-swiftclient,
and awkward to change because swift is a command line program
often used from scripts.

Note that swift-im is used in ubuntu for example.
Hopefully this will not impact too much, as it's
less likely that swift[-im] is used in scripts,
and be hidden from users as they would be using a launcher.

Ideally this change would be made on F17 and F18

thanks!
Comment 1 Alan Pevec 2012-10-04 11:22:05 EDT
Upstream fix for Debian
http://swift.im/git/swift/commit/?id=cacc0b6839f7894f51adfd119bf19846fa8bdb61
Comment 2 Jan Kaluža 2012-10-05 06:11:31 EDT
Upstream should release new version (which includes renamed binary) this weekend. It should have been released one week ago... I didn't want to build new packages just with this change, but if they won't release this weekend, I will do it.
Comment 3 Fedora Update System 2012-10-10 02:22:11 EDT
swift-2.0-0.3.beta2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/swift-2.0-0.3.beta2.fc18
Comment 4 Fedora Update System 2012-10-10 14:08:08 EDT
Package swift-2.0-0.3.beta2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing swift-2.0-0.3.beta2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15816/swift-2.0-0.3.beta2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 11:21:27 EST
swift-2.0-0.3.beta2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.