Bug 857911 - 'Displays' module of control-center - can't choose a monitor miniature
'Displays' module of control-center - can't choose a monitor miniature
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 09:18 EDT by Vitezslav Humpa
Modified: 2014-06-13 07:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:48:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-09-17 09:18:02 EDT
Description of problem:
With control-center-3.5.91-1.fc18.x86_64 coming into rhel7 out of F18, the 'Displays' module is severely broken. If more than one display is present, it's not possible to choose other display using the graphical miniatures as well as it's not possible to transfer a 'top panel' symbolics. 

Version-Release number of selected component (if applicable):
control-center-3.5.91-1.fc18.x86_64

How reproducible:
Always it seems

Steps to Reproduce:
1. Open 'System Settings'
2. Click 'Displays'
3. Try to click some other display miniature
Comment 1 Matthias Clasen 2012-10-12 20:01:04 EDT
This is caused by a cairo bug, as far as I know: https://bugs.freedesktop.org/show_bug.cgi?id=54732

It is fixed in cairo 1.12.4, which will find its way into f18 shortly.
Comment 2 Bastien Nocera 2012-10-15 11:31:14 EDT
Should be fixed now. Please check again.
Comment 3 Vladimir Benes 2013-01-16 11:07:17 EST
fixed now
-> VERIFIED
Comment 4 Ludek Smid 2014-06-13 07:48:08 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.