Bug 857913 - Auto-stop option in katello-upgrade does not work
Auto-stop option in katello-upgrade does not work
Status: CLOSED DUPLICATE of bug 858360
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Og Maciel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 09:18 EDT by Lukas Zapletal
Modified: 2013-03-27 16:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The katello-upgrade script includes stopping all necessary services for the upgrade. This provides less steps to the upgrade process and ensure a smoother transition.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 11:41:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-09-17 09:18:54 EDT
# katello-upgrade -y -a -s
Service 'katello' can not be running while katello-upgrade is in progress
Service 'katello-jobs' can not be running while katello-upgrade is in progress
Service 'tomcat6' can not be running while katello-upgrade is in progress
Service 'pulp-server' can not be running while katello-upgrade is in progress
Service 'httpd' can not be running while katello-upgrade is in progress
Service 'elasticsearch' can not be running while katello-upgrade is in progress
================================================================================
We will stop all katello services using katello-service stop.
PROCEED? (y/n): y
katello-service: unrecognized service
There was an issue stopping your services. Please resolve this manually
and try again
Comment 1 Lukas Zapletal 2012-09-17 11:21:51 EDT
https://github.com/Katello/katello/pull/679
Comment 4 Og Maciel 2012-09-25 17:17:57 EDT
# katello-upgrade -y -a -s
Service 'katello' can not be running while katello-upgrade is in progress
Service 'katello-jobs' can not be running while katello-upgrade is in progress
Service 'tomcat6' can not be running while katello-upgrade is in progress
Service 'pulp-server' can not be running while katello-upgrade is in progress
Service 'httpd' can not be running while katello-upgrade is in progress
Service 'elasticsearch' can not be running while katello-upgrade is in progress
================================================================================
We will stop all katello services.
PROCEED? (y/n): y
Shutting down Katello services...
Stopping katello: 
Stopping elasticsearch:                                    [  OK  ]
Stopping httpd:                                            [  OK  ]
Stopping Qpid AMQP daemon:                                 [  OK  ]
Stopping mongod:                                           [  OK  ]
Stopping httpd:                                            [FAILED]
Stopping tomcat6:                                          [  OK  ]
Done.
================================================================================
 Katello upgrade
================================================================================
Nothing to do
[root@qetello02 ~]# katello -u admin -p admin ping
Connection refused
[root@qetello02 ~]#
Comment 5 Og Maciel 2012-09-25 17:26:55 EDT
FailedQA. Systems should have been restarted even if there were no upgrades available.

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-9.el6cf.noarch
* katello-all-1.1.12-9.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-5.el6cf.noarch
* katello-cli-common-1.1.8-5.el6cf.noarch
* katello-common-1.1.12-9.el6cf.noarch
* katello-configure-1.1.9-4.el6cf.noarch
* katello-glue-candlepin-1.1.12-9.el6cf.noarch
* katello-glue-pulp-1.1.12-9.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 6 Mike McCune 2012-09-26 11:37:00 EDT
Ideally it would restart the services when it is complete but it has never done this so I wouldn't say this bug FailsQA since it appears to be doing what we intended.
Comment 7 Mike McCune 2012-09-26 11:41:45 EDT
ignore what I said above, original RFE states start+stop

closing as a dupe

*** This bug has been marked as a duplicate of bug 858360 ***

Note You need to log in before you can comment on or make changes to this bug.