Bug 858015 - [RFE] Make scl-utils environment-modules friendly
[RFE] Make scl-utils environment-modules friendly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 965565 854744 971873
  Show dependency treegraph
 
Reported: 2012-09-17 15:25 EDT by Travis Gummels
Modified: 2016-07-10 22:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 971873 (view as bug list)
Environment:
Last Closed: 2013-08-26 08:03:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Gummels 2012-09-17 15:25:54 EDT
Description of problem:

environment-modules users may wish to continue to use "modules" for product delivered that works with scl.  Providing the capability for scl to work with environment-modules would be appreciated.

Version-Release number of selected component (if applicable):
scl-utils current
environment-modules current

How reproducible:
100%

Actual results:
End users have to repackage components that come in scl packaging to work with environment-modules

Expected results:
scl packaged components work out of the box with environment-modules

Additional info:
Comment 2 Matthew Miller 2012-12-05 10:42:33 EST
I think this would be a huge win. Environment modules is well-established in the HPC community (where Fedora and ultimately-derived-from-Fedora distributions are very popular).

Plus, we already have environment-modules in Fedora and in RHEL (used for different versions of mpi), and it'd be nice if all our stuff played nicely together.
Comment 3 Fedora Admin XMLRPC Client 2013-03-13 10:26:18 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Jan Zeleny 2013-08-26 08:03:58 EDT
After a lot of thought I have decided to close this one. The core concept of scl-utils is a bit different than the one of env. modules and there is virtually nothing scl-utils can do to significantly improve the support.

The burden of the better support is up to the collection maintainers to transform their scriptlets to env. modules. The good new is that it is much more simple than it sounds. The only thing that needs to be done is to use either [1] or [2] (both part of the environment-modules package) to transform collection's scriptlet to an env. module and then (if necessary) to copy that module to $MODULESHOME/init. All this can be done in the %pre stage right after the scl scriptlet is created (don't forget that the package has to pre-require the environment-modules).


[1] /usr/share/Modules/bin/createmodule.sh
[2] /usr/share/Modules/bin/createmodule.py
Comment 5 Nick Coghlan 2016-07-10 22:05:21 EDT
Since this BZ came first in a search for "scl-utils environment modules", just adding a link directly to the documentation for the approach Jan describes above: https://www.softwarecollections.org/en/docs/guide/#sect-Converting_Software_Collection_Scriptlets_into_Environment_Modules

Note You need to log in before you can comment on or make changes to this bug.