Bug 858047 - SELinux is preventing /usr/sbin/setfiles from 'getattr' accesses on the filesystem /dev/hugepages.
SELinux is preventing /usr/sbin/setfiles from 'getattr' accesses on the files...
Status: CLOSED DUPLICATE of bug 858045
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4d34a4e84fd0373ebe7ed3f6347...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 16:57 EDT by Flóki Pálsson
Modified: 2012-09-17 18:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-17 16:57 EDT, Flóki Pálsson
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-17 16:57 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2012-09-17 16:57:32 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64

description:
:SELinux is preventing /usr/sbin/setfiles from 'getattr' accesses on the filesystem /dev/hugepages.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that setfiles should be allowed getattr access on the hugepages filesystem by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep restorecon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewalld_t:s0
:Target Context                system_u:object_r:hugetlbfs_t:s0
:Target Objects                /dev/hugepages [ filesystem ]
:Source                        restorecon
:Source Path                   /usr/sbin/setfiles
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           policycoreutils-2.1.12-5.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-18.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc2.git2.1.fc18.x86_64 #1
:                              SMP Wed Aug 22 11:54:04 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-09-17 20:51:42 GMT
:Last Seen                     2012-09-17 20:51:42 GMT
:Local ID                      b120e9f2-2129-4f6c-ad74-805154efddf2
:
:Raw Audit Messages
:type=AVC msg=audit(1347915102.636:369): avc:  denied  { getattr } for  pid=2127 comm="restorecon" name="/" dev="hugetlbfs" ino=12559 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=filesystem
:
:
:type=SYSCALL msg=audit(1347915102.636:369): arch=x86_64 syscall=statfs success=no exit=EACCES a0=7f8f46aa639a a1=7fff02b68520 a2=7f8f46aa639a a3=72207366626c7465 items=0 ppid=603 pid=2127 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=restorecon exe=/usr/sbin/setfiles subj=system_u:system_r:firewalld_t:s0 key=(null)
:
:Hash: restorecon,firewalld_t,hugetlbfs_t,filesystem,getattr
:
:audit2allow
:
:#============= firewalld_t ==============
:allow firewalld_t hugetlbfs_t:filesystem getattr;
:
:audit2allow -R
:
:#============= firewalld_t ==============
:allow firewalld_t hugetlbfs_t:filesystem getattr;
:
Comment 1 Flóki Pálsson 2012-09-17 16:57:35 EDT
Created attachment 613780 [details]
File: type
Comment 2 Flóki Pálsson 2012-09-17 16:57:36 EDT
Created attachment 613781 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-09-17 18:47:33 EDT

*** This bug has been marked as a duplicate of bug 858045 ***

Note You need to log in before you can comment on or make changes to this bug.