Bug 858059 - [abrt] system-config-language-1.3.5-12.fc18: __init__.py:3534:selectGroup:GroupsError: No Group named portuguese-support exists
[abrt] system-config-language-1.3.5-12.fc18: __init__.py:3534:selectGroup:Gro...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
abrt_hash:441e58ea37857acb23d0ac586c5...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 18:23 EDT by Sergio
Modified: 2015-04-12 19:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: system-config-language-1.4.0-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:06:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (323 bytes, text/plain)
2012-09-17 18:24 EDT, Sergio
no flags Details

  None (edit)
Description Sergio 2012-09-17 18:23:59 EDT
Description of problem:
Trying to set 'Portuguese (Brazil)' as the default system language from system-config-language yum didn't find a portuguese-support group.

Version-Release number of selected component:
system-config-language-1.3.5-12.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.11
cmdline:        /usr/bin/python /usr/share/system-config-language/system-config-language.py
kernel:         3.6.0-0.rc2.git2.1.fc18.i686

backtrace:
:__init__.py:3534:selectGroup:GroupsError: No Group named portuguese-support exists
:
:Traceback (most recent call last):
:  File "/usr/share/system-config-language/language_gui.py", line 179, in okClicked
:    self.apply()
:  File "/usr/share/system-config-language/language_gui.py", line 272, in apply
:    install.selectGroup(grpid)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3534, in selectGroup
:    raise Errors.GroupsError, _("No Group named %s exists") % to_unicode(grpid)
:GroupsError: No Group named portuguese-support exists
:
:Local variables in innermost frame:
:group_package_types: []
:upgrade: False
:ievgrp: None
:self: <gui_install.guiInstall object at 0x96f5b0c>
:grpid: 'portuguese-support'
:enable_group_conditionals: None
Comment 1 Sergio 2012-09-17 18:24:02 EDT
Created attachment 613805 [details]
File: core_backtrace
Comment 2 Sergio 2012-09-17 18:26:27 EDT
rc3-alpha xfce spin live-cd
Related to bug https://bugzilla.redhat.com/show_bug.cgi?id=858056
Comment 3 Fedora Update System 2012-09-20 07:26:36 EDT
system-config-language-1.3.5-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-13.fc17
Comment 4 Fedora Update System 2012-09-20 07:27:01 EDT
system-config-language-1.3.5-13.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-13.fc18
Comment 5 Fedora Update System 2012-09-21 19:56:40 EDT
Package system-config-language-1.3.5-13.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-language-1.3.5-13.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14443/system-config-language-1.3.5-13.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-11-02 08:52:18 EDT
system-config-language-1.3.5-14.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-14.fc18
Comment 7 Fedora Update System 2012-11-02 08:52:52 EDT
system-config-language-1.3.5-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-14.fc17
Comment 8 Fedora Update System 2012-12-20 11:27:39 EST
system-config-language-1.3.5-14.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 lnxslck 2013-11-01 05:30:26 EDT
This problem still persists. I'm running Fedora 19 x64, and was trying to set the System language to Portuguese (Portugal) through system-config-language and i got that error.

So bug is not closed.
Comment 10 anish 2013-11-07 07:00:01 EST
Coms has removed some of support for language groups based on below irc discussion,however system-config-language should not throw an error, it should change system's locale accordingly


<anish_> tagoh_, in comps https://git.fedorahosted.org/cgit/comps.git/tree/comps-f9.xml.in
<anish_> we have group called "portuguese-support" but still i am getting None
<tagoh_> f9!?
<anish_> yes in f19 and f20 as well 
<tagoh_> well, language support in comps should be gone
<anish_> if this is the case then why i am getting correct values for Marathi 
<anish_> and apparently system-config-language uses this code
<anish_> what should be appropriate behaviour then? 
<tagoh_> commit b1a8357d41db0afa8cc95e100bb0c7c6678f3e10
<tagoh_> Author: Bill Nottingham <notting@redhat.com>
<tagoh_> Date:   Fri Feb 24 15:47:02 2012 -0500
<tagoh_>     Drop empty or effiectively empty (only contains dejavu) language support groups.
<tagoh_> portuguese-support group has been removed with it
<juhp> mfabian: yeah I think it is not in
<tagoh_> anish_: what release did you try?
<anish_> i tried this on F20 
<tagoh_> no wonder then
<anish_> even on F19 as well 
<anish_> so in future Marathi support will also gone right
* skore (~skore@14.97.175.35) has joined #fedora-i18n
<tagoh_> if no particular packages needs to be installed, yes
<tagoh_> the kind of yum langinstall may be more useful
<anish_> tagoh_, thanks! currently system config language gives an error "No Group named portuguese-support exists" while installing Portugese 
<tagoh_> "doesn't exist" you mean?
<anish_> yes
<tagoh_> yep, that sounds correct
<anish_> tagoh_, https://bugzilla.redhat.com/show_bug.cgi?id=858059
<anish_> i will close this bug as not a bug then 
<tagoh_> anish_: that sounds like the expected behavior should be no error for Portuguese though
<anish_> tagoh_, i don't get "no error for Portuguese"
<anish_> if there is no group for "Portuguese" then how would s-c-l can install packages 
<tagoh_> as the reporter still complain at comment#9, they seem still seeing an error.
<anish_> related to "Portuguese"
<tagoh_> it's not a language-related package installer right? :)
<tagoh_> the main purpose should be to change the language for system. if no lang group in comps, s-c-language could just ignore that error IMHO
<anish_> okay thanks i will do that changes 
<anish_> just wanted to confirm before doing that
Comment 11 Fedora Update System 2013-11-07 07:01:46 EST
system-config-language-1.4.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-4.fc20
Comment 12 Fedora Update System 2013-11-07 07:02:01 EST
system-config-language-1.4.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-4.fc19
Comment 13 Fedora Update System 2013-11-07 14:12:01 EST
Package system-config-language-1.4.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-language-1.4.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20885/system-config-language-1.4.0-4.fc20
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-11-22 00:04:27 EST
system-config-language-1.4.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-5.fc19
Comment 15 Fedora Update System 2013-11-22 00:04:53 EST
system-config-language-1.4.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-5.fc20
Comment 16 Fedora Update System 2013-12-10 01:51:17 EST
system-config-language-1.4.0-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-6.fc20
Comment 17 Fedora Update System 2013-12-10 01:51:44 EST
system-config-language-1.4.0-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-6.fc19
Comment 18 lnie 2013-12-10 02:24:12 EST
tested with 1.4.0-5.fc20 and 1.4.0-6.fc20,both work fine
Comment 19 Fedora Update System 2013-12-13 22:06:06 EST
system-config-language-1.4.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2014-01-15 23:39:26 EST
system-config-language-1.4.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-7.fc20
Comment 21 Fedora Update System 2014-01-16 02:17:12 EST
system-config-language-1.4.0-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2014-01-18 23:02:09 EST
system-config-language-1.4.0-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.