Bug 858088 - ISO file option still shown on 'installation source' spoke if no viable source is available, if you once entered the spoke when one was
ISO file option still shown on 'installation source' spoke if no viable sourc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 19:26 EDT by Adam Williamson
Modified: 2012-11-22 21:15 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-18.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:15:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-09-17 19:26:41 EDT
The 'installation source' spoke is meant to only show the option to install from an ISO file if there's a viable source for one. To put it in negative terms, if the currently-planned partitioning scheme involves reformatting all available disks, the option is supposed not to be shown because there's no place you could possibly get an ISO file from.

This works OK if you only enter the 'installation source' spoke after going to 'installation destination' and picking such a partition scheme - say there's only one disk on the system, and you pick it for auto-partitioning in F18 Alpha (which means it'll be reformatted). If you then go to 'installation destination', the ISO file option is not shown.

However, it breaks if you enter 'installation source' *before* entering 'installation destination'. The ISO file will be shown when you first enter 'installation source' - which is correct - but it'll still be shown even if you then go into 'installation destination', select all available disks for formatting, and then re-enter 'installation source', which is *not* correct. In this case, anaconda should recognize that the planned partition scheme has changed, and no longer show the option. (It should also probably warn the user and void the 'installation source' selection if the user picks an ISO file as the install source and then selects the partition where the ISO file resides for formatting in 'installation destination'; I haven't checked yet if that's in place).

dlehman reckons this is because "we have code to set it visible on refresh, but no code to set it invisible on refresh (if I'm seeing this right)" and suggests http://fpaste.org/B2Ch/ as a possible patch.
Comment 1 Chris Lumens 2012-09-19 11:10:17 EDT
That looks like a suspiciously short patch, but I could put together an updates image to test if you have a test setup.  I hate testing hdiso.
Comment 2 Adam Williamson 2012-09-19 18:49:05 EDT
You don't actually have to complete an install or even have an ISO image on the test system to test this bug. You just have to clicky clicky between the spokes as described in the report. I'm just testing it in my usual test VM.

I'll happily test it if you give me an updates image.
Comment 3 Chris Lumens 2012-09-20 16:33:06 EDT
I don't think that patch works.
Comment 4 Chris Lumens 2012-09-20 16:55:13 EDT
But now I have a better plan - one that excludes the blob's stupid mother.
Comment 5 Adam Williamson 2012-11-22 21:15:23 EST
Confirmed fixed now (Beta RC1, but certainly much earlier) - cannot reproduce as per above.

Note You need to log in before you can comment on or make changes to this bug.