Bug 858128 - libguestfs fail to list devices added by add-drive-ro-with-if twice
libguestfs fail to list devices added by add-drive-ro-with-if twice
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 23:19 EDT by Mohua Li
Modified: 2013-02-21 03:38 EST (History)
4 users (show)

See Also:
Fixed In Version: libguestfs-1.16.31-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:38:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2012-09-17 23:19:17 EDT
Description of problem:

added 2 devices by add-drive-ro-with-if, will get error result, but if just=
 added 1 device won't have this problem,=20
><fs> add-drive-ro-with-if  ide.img ide=20
><fs> add-drive-ro-with-if  virtio.img virtio
><fs>list-devices
libguestfs: trace: list_devices
libguestfs: send_to_daemon: 44 bytes: 00 00 00 28 | 20 00 f5 f5 | 00 00 00 =
04 | 00 00 00 07 | 00 00 00 00 | ...
guestfsd: main_loop: new request, len 0x28
guestfsd: guestfsd.c:556: compare_device_names: Assertion `r =3D=3D 1' fail=
ed.
/init: line 151:   301 Aborted                 $vg guestfsd
[    5.800056] md: stopping all md devices.
[    5.800827] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[    5.956143] Restarting system.
[    5.956656] machine restart
libguestfs: child_cleanup: 0xeb1c00: child process died
libguestfs: trace: list_devices =3D NULL (error)



Version-Release number of selected component (if applicable):
libguestfs-1.16.30-2.el6.x86_64

How reproducible:
always 

Steps to Reproduce:
1. qemu-img create ide.img 1G; qemu-img create virtio.img 1G;=20
2. guestfish -x -v add-drive-ro-with-if ide.img ide : add-drive-ro-with-if =
virtio.img virtio : run : list-devices=20
3. no problem with:  guestfish -x -v add-drive ide.img : add-drive virtio.i=
mg  : run : list-devices

  
Actual results:


Expected results:


Additional info:
this is a regression bug, only happen on 6.4 build, no problem with 6.3 RC build
Comment 3 Richard W.M. Jones 2012-09-28 09:21:09 EDT
I can reproduce this bug in RHEL 6.4.

Upstream, the same command hangs libguestfs ...  This
is not necessarily surprising because (upstream) this
tries to add an IDE disk, a virtio-blk disk, and a virtio-scsi
disk to the same guest, which seems unlikely to work,
and even less likely to be a good idea.

However I will try to fix this for RHEL 6.
Comment 4 Richard W.M. Jones 2012-09-28 10:09:36 EDT
Fixed upstream in commit d57511e00c9e40ea895edd48953f3ab094a29bb0.
Comment 5 Richard W.M. Jones 2012-09-28 10:10:27 EDT
(In reply to comment #4)
> Fixed upstream in commit d57511e00c9e40ea895edd48953f3ab094a29bb0.

Ignore that.

The correct commit is 6f53d49a27fbf7f1b5c22080e2509375e128d5e4.
Comment 9 errata-xmlrpc 2013-02-21 03:38:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0324.html

Note You need to log in before you can comment on or make changes to this bug.