This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 858129 - Segmentation fault after performing lvconvert --thinpool vg/thick
Segmentation fault after performing lvconvert --thinpool vg/thick
Status: CLOSED DUPLICATE of bug 858874
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks: 858874
  Show dependency treegraph
 
Reported: 2012-09-17 23:36 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858874 (view as bug list)
Environment:
Last Closed: 2012-10-08 08:07:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lvconvert.log (58.14 KB, text/plain)
2012-09-27 04:07 EDT, Xiaowei Li
no flags Details

  None (edit)
Description Xiaowei Li 2012-09-17 23:36:37 EDT
Description of problem:
Segmentation fault after performing lvconvert --thinpool vg/thick


Version-Release number of selected component (if applicable):
lvm2-2.02.97-1.el7.x86_64

How reproducible:


Steps to Reproduce:
1.lvcreate -l10 -n vg/thick
2.lvconvert --thinpool vg/thick -vvvv
attaching the debug log.
  
Actual results:
Segmentation fault (core dumped)

# lvs -a vg
  LV            VG   Attr     LSize  Pool Origin Data%  Move Log Copy%  Convert
  [thick_tdata] vg   Twi---t- 40.00m                                           
  [thick_tmeta] vg   twi---t- 40.00m   

# dmesg
>>>
[66842.263751] lvconvert[4058]: segfault at 7fff24467fd8 ip 0000003340a46b7b sp 00007fff24467fe0 error 6 in libc-2.16.so[3340a00000+1ad000]
>>>

Expected results:


Additional info:
Comment 4 Xiaowei Li 2012-09-27 04:06:42 EDT
I also hit it on fedora 18 alpha.

attaching the lvconvert -vvvv log file.

=== backtrace ===
Core was generated by `lvconvert --thinpool vg/thick'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000000045e808 in print_log ()
Missing separate debuginfos, use: debuginfo-install lvm2-2.02.97-1.fc18.x86_64
(gdb) bt
#0  0x000000000045e808 in print_log ()
#1  0x0000003eaac29306 in dm_task_run () from /lib64/libdevmapper.so.1.02
#2  0x0000000000495d04 in ?? ()
#3  0x0000000000495eb5 in ?? ()
#4  0x0000000000496a49 in ?? ()
#5  0x0000000000496d35 in ?? ()
#6  0x0000000000496f9d in ?? ()
#7  0x0000000000496f9d in ?? ()
#8  0x0000000000496f9d in ?? ()
#9  0x0000000000496f9d in ?? ()
#10 0x0000000000496f9d in ?? ()
#11 0x0000000000496f9d in ?? ()
#12 0x0000000000496f9d in ?? ()
#13 0x0000000000496f9d in ?? ()
#14 0x0000000000496f9d in ?? ()
#15 0x0000000000496f9d in ?? ()
Comment 5 Xiaowei Li 2012-09-27 04:07:19 EDT
Created attachment 617939 [details]
lvconvert.log
Comment 6 Zdenek Kabelac 2012-10-08 08:07:11 EDT

*** This bug has been marked as a duplicate of bug 858874 ***

Note You need to log in before you can comment on or make changes to this bug.