Bug 858145 - [virtio-win][serial]qemu-kvm quit due to "Guest moved used index from 114 to 0" when doing S3 and S4 during transferring data from host to guest
[virtio-win][serial]qemu-kvm quit due to "Guest moved used index from 114 to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
: 870716 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 03:00 EDT by Mike Cao
Modified: 2015-11-22 22:36 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:27:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-09-18 03:00:30 EDT
Description of problem:
During Guest tranferring data from host to guest ,then do s3 , qemu-kvm process will quit due to "Guest moved used index from 114 to 0"

Version-Release number of selected component (if applicable):
2.6.32-307.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.312.el6.x86_64
virtio-win-prewhql-35

How reproducible:
2/2

Steps to Reproduce:
1.Start VM with virtio-serial-pci and virtserialport
CLI:/usr/libexec/qemu-kvm -M rhel6.4.0 -cpu SandyBridge -enable-kvm -m 4096 -smp 4 -name win7-ser -uuid 95f5b887-b59f-48ab-9a7c-4024e31de64b -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/rhev/data-center/0bbd954a-b9dd-4075-accc-73da9f3f4f9f/adeb4775-27dc-4e92-a720-6609719abd49/images/e5b7e352-5bc3-437a-8958-905019614b0e/aa772688-9948-4ffa-b50b-14c20911e73e,if=none,id=drive-ide0-0-0,format=raw,serial=e5b7e352-5bc3-437a-8958-905019614b0e,cache=none,werror=stop,rerror=stop,aio=threads -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/rhev/data-center/0bbd954a-b9dd-4075-accc-73da9f3f4f9f/7db7d438-49c0-403c-98bb-86e1eb368cbf/images/11111111-1111-1111-1111-111111111111/en_windows_7_ultimate_with_sp1_x64_dvd_618240.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:1a:4a:42:04:8b,bus=pci.0,addr=0x3,bootindex=3 -chardev socket,id=charchannel0,path=/tmp/tt,server,nowait  -spice port=5902,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -bios /usr/share/seabios/bios-pm.bin -fda /home/iso/7db7d438-49c0-403c-98bb-86e1eb368cbf/images/11111111-1111-1111-1111-111111111111/virtio-win.vfd -monitor stdio  -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 -device virtserialport,bus=virtio-serial0.0,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/tmp/tt1,server,nowait -device virtserialport,bus=virtio-serial0.0,chardev=charchannel1,name=com.redhat.rhevm.vdsm1
2.Transferring data from host to guest 
eg : in the guest 
for ((;;)) ; do python VirtIOChannel-guest-recieve.py com.redhat.rhevm.vsdm ;done
on the host 
for ((;;)); do  python serial-host-send.py /tmp/tt; echo `uuidgen`;sleep 0.5 ; done
3.sleep guest 
  
Actual results:
qemu-kvm quit due to "Guest moved used index from 114 to 0"

Expected results:
sleep successfully

Additional info:
We did not find this bug during previous verison Testing ,this should be regression
Comment 3 Dor Laor 2012-09-24 03:30:31 EDT
Mike, is that an issue of qemu or the drivers? Is a previous version of qemu survive this?

In general, since we do have some s3 left over issues I rather wait w/ it for rhel6.5 but in case this is a new regression we can solve it now
Comment 4 Mike Cao 2012-09-24 03:37:45 EDT
(In reply to comment #3)
> Mike, is that an issue of qemu or the drivers? Is a previous version of qemu
> survive this?
> 
should be the issues in the driver ,We have such test case and did not hit it before ,this should be virtio-win regression introduced recently.

> In general, since we do have some s3 left over issues I rather wait w/ it
> for rhel6.5 but in case this is a new regression we can solve it now
Comment 6 Mike Cao 2012-10-30 03:48:03 EDT
*** Bug 870716 has been marked as a duplicate of this bug. ***
Comment 7 Qunfang Zhang 2012-11-27 04:04:57 EST
Hit this problem when do S3 and S4 during transferring data between host and guest.
Comment 8 Mike Cao 2012-12-06 00:32:57 EST
Verified this issue on virtio-win-prehwql-49

steps same as comment#0

Actual Results:
on build 49 ,qemu-kvm does not quit

Based on above ,this issue has been fixed in build 49 ald 

Move status to verified.

Note You need to log in before you can comment on or make changes to this bug.