Bug 858170 - HotPlugDiskToVmCommand throw exception: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
HotPlugDiskToVmCommand throw exception: java.lang.IndexOutOfBoundsException: ...
Status: CLOSED DUPLICATE of bug 854141
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
All All
urgent Severity medium
: ---
: 3.1.0
Assigned To: Nobody's working on this, feel free to take it
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 05:04 EDT by Lee Yarwood
Modified: 2016-02-10 13:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 16:54:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (2.69 MB, text/x-log)
2012-09-18 06:30 EDT, Lee Yarwood
no flags Details

  None (edit)
Description Lee Yarwood 2012-09-18 05:04:48 EDT
Description of problem:

Hot plugging a LUN on si14 fails with the following traceback within engine.log (attached) :

11327 2012-09-04 14:28:02,336 INFO  [org.ovirt.engine.core.bll.HotPlugDiskToVmCommand] (pool-4-thread-48) [323e8788] Running command: HotPlugDiskToVmCommand internal: false. Entities affected :  ID: ef69b374-6113-4fc0-9882-2fae      20bb21b0 Type: VM
11328 2012-09-04 14:28:02,337 ERROR [org.ovirt.engine.core.bll.HotPlugDiskToVmCommand] (pool-4-thread-48) [323e8788] Command org.ovirt.engine.core.bll.HotPlugDiskToVmCommand throw exception: java.lang.IndexOutOfBoundsException:       Index: 0, Size: 0
11329     at java.util.ArrayList.rangeCheck(ArrayList.java:604) [rt.jar:1.7.0_05-icedtea]
11330     at java.util.ArrayList.get(ArrayList.java:382) [rt.jar:1.7.0_05-icedtea]
11331     at org.ovirt.engine.core.bll.AbstractDiskVmCommand.performPlugCommnad(AbstractDiskVmCommand.java:57) [engine-bll.jar:]
11332     at org.ovirt.engine.core.bll.HotPlugDiskToVmCommand.ExecuteVmCommand(HotPlugDiskToVmCommand.java:69) [engine-bll.jar:]
11333     at org.ovirt.engine.core.bll.VmCommand.executeCommand(VmCommand.java:82) [engine-bll.jar:]
11334     at org.ovirt.engine.core.bll.CommandBase.ExecuteWithoutTransaction(CommandBase.java:810) [engine-bll.jar:]
11335     at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:901) [engine-bll.jar:]
11336     at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1256) [engine-bll.jar:]
11337     at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:168) [engine-utils.jar:]
11338     at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:107) [engine-utils.jar:]
11339     at org.ovirt.engine.core.bll.CommandBase.Execute(CommandBase.java:916) [engine-bll.jar:]
11340     at org.ovirt.engine.core.bll.CommandBase.ExecuteAction(CommandBase.java:275) [engine-bll.jar:]
11341     at org.ovirt.engine.core.bll.MultipleActionsRunner.executeValidatedCommands(MultipleActionsRunner.java:182) [engine-bll.jar:]
11342     at org.ovirt.engine.core.bll.MultipleActionsRunner.RunCommands(MultipleActionsRunner.java:162) [engine-bll.jar:]
11343     at org.ovirt.engine.core.bll.MultipleActionsRunner$1.run(MultipleActionsRunner.java:84) [engine-bll.jar:]
11344     at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:64) [engine-utils.jar:]
11345     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_05-icedtea]
11346     at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_05-icedtea]
11347     at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_05-icedtea]
11348     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05-icedtea]
11349     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05-icedtea]
11350     at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05-icedtea]

BZ#854141 corrected the same error within RunVmCommandBase. It looks like we just need to apply the same !lun.getLunConnections().isEmpty() check within AbstractDiskVmCommand.

Version-Release number of selected component (if applicable):
si14

How reproducible:
Unable to reproduce internally with later builds.
Comment 1 Lee Yarwood 2012-09-18 06:30:00 EDT
Created attachment 613954 [details]
engine.log
Comment 3 Itamar Heim 2012-09-18 16:54:01 EDT
please re-open if re-surfaces post si18, per bug 854141

*** This bug has been marked as a duplicate of bug 854141 ***

Note You need to log in before you can comment on or make changes to this bug.