Bug 858188 - Error sending systemd notify while starting keystone
Error sending systemd notify while starting keystone
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-keystone (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 05:41 EDT by Derek Higgins
Modified: 2012-10-23 13:48 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 13:48:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2012-09-18 05:41:12 EDT
Error while running

> sudo openstack-demo-install
<snip/>
======= Setting up Keystone ======
Redirecting to /bin/systemctl start  openstack-keystone.service
Job failed. See system journal and 'systemctl status' for details.
[stack@localhost ~]$


Excerpt from /var/log/message
Sep 18 08:49:38 localhost keystone-all[2343]: Traceback (most recent call last):
Sep 18 08:49:38 localhost keystone-all[2343]: File "/usr/bin/keystone-all", line 105, in <module>
Sep 18 08:49:38 localhost keystone-all[2343]: serve(*servers)
Sep 18 08:49:38 localhost keystone-all[2343]: File "/usr/bin/keystone-all", line 59, in serve
Sep 18 08:49:38 localhost keystone-all[2343]: notifier.notify()
Sep 18 08:49:38 localhost keystone-all[2343]: File "/usr/lib/python2.7/site-packages/keystone/common/systemd.py", line 36, in notify
Sep 18 08:49:38 localhost keystone-all[2343]: _sd_notify('READY=1')
Sep 18 08:49:38 localhost keystone-all[2343]: File "/usr/lib/python2.7/site-packages/keystone/common/systemd.py", line 30, in _sd_notify
Sep 18 08:49:38 localhost keystone-all[2343]: sock.connect(sysd)
Sep 18 08:49:38 localhost keystone-all[2343]: File "/usr/lib/python2.7/site-packages/eventlet/greenio.py", line 167, in connect
Sep 18 08:49:38 localhost keystone-all[2343]: while not socket_connect(fd, address):
Sep 18 08:49:38 localhost keystone-all[2343]: File "/usr/lib/python2.7/site-packages/eventlet/greenio.py", line 37, in socket_connect
Sep 18 08:49:38 localhost keystone-all[2343]: raise socket.error(err, errno.errorcode[err])
Sep 18 08:49:38 localhost keystone-all[2343]: socket.error: [Errno 2] ENOENT
Comment 1 Alan Pevec 2012-09-18 05:56:29 EDT
Here's quick workaround, so you can continue testing: comment onready in /etc/keystone/keystone.conf and start keystone-all manually from shell.
Comment 2 Mark McLoughlin 2012-09-18 08:22:55 EDT
Rather than starting keystone manually from the shell, do:

sudo sed -i 's/Type=notify/Type=simple/' /usr/lib/systemd/system/openstack-keystone.service

and you'll be able to start it with systemctl
Comment 3 Alan Pevec 2012-09-18 10:44:40 EDT
Just to be clear, you need both remove onready from keystone.conf and change service type to simple.
Root cause found bug: 820448 comment 3, patch for Keystone coming.
Comment 4 Alan Pevec 2012-09-18 18:33:34 EDT
upstream fix https://review.openstack.org/13237
Comment 5 Fedora Update System 2012-09-21 13:00:10 EDT
openstack-keystone-2012.2-0.8.rc1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-14211/openstack-keystone-2012.2-0.8.rc1.fc18
Comment 6 Fedora Update System 2012-09-22 02:32:22 EDT
Package openstack-keystone-2012.2-0.8.rc1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-keystone-2012.2-0.8.rc1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14211/openstack-keystone-2012.2-0.8.rc1.fc18
then log in and leave karma (feedback).
Comment 7 Pádraig Brady 2012-09-25 07:00:51 EDT
I'm getting a related failure when starting keystone:

======= Setting up Keystone ======
Redirecting to /bin/systemctl start  openstack-keystone.service
Note: Forwarding request to 'systemctl enable openstack-keystone.service'.
ln -s '/usr/lib/systemd/system/openstack-keystone.service' '/etc/systemd/system/multi-user.target.wants/openstack-keystone.service'
Failed to issue method call: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[root@localhost ~]# rpm -q openstack-keystone
openstack-keystone-2012.2-0.8.rc1.fc18.noarch
[root@localhost ~]# getenforce
Permissive
[root@localhost ~]# rpm -q systemd
systemd-188-3.fc18.x86_64
Comment 8 Alan Pevec 2012-09-25 18:41:46 EDT
I couldn't reproduce comment 7 - could anyone provide reliable steps to reproduce?
Comment 9 Fedora Update System 2012-09-27 20:13:53 EDT
Package openstack-keystone-2012.2-0.9.rc2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-keystone-2012.2-0.9.rc2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14211/openstack-keystone-2012.2-0.9.rc2.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-09-27 20:36:36 EDT
openstack-keystone-2012.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-14211/openstack-keystone-2012.2-1.fc18
Comment 11 Fedora Update System 2012-09-28 13:22:19 EDT
Package openstack-keystone-2012.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-keystone-2012.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14211/openstack-keystone-2012.2-1.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.