Bug 858227 - AVC denials with subscription manager
AVC denials with subscription manager
Status: CLOSED DUPLICATE of bug 870542
Product: Fedora
Classification: Fedora
Component: subscription-manager (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Devan Goodwin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-09-18 07:17 EDT by Miroslav Suchý
Modified: 2013-01-10 06:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 15:21:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2012-09-18 07:17:35 EDT
Description of problem:
I installed Katello and after installation I see lots of AVC denial from subscription manager.

Version-Release number of selected component (if applicable):
subscription-manager-1.0.13-1.fc16.x86_64

How reproducible:
deterministic

Steps to Reproduce:
1. Install Katello - I do not have minimalistic reproducer :(
  
Actual results:
type=AVC msg=audit(1347962853.269:310): avc:  denied  { execute } for  pid=8766 comm="rhsmcertd-worke" name="bash" dev="dm-1" ino=1179651 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.269:310): avc:  denied  { read open } for  pid=8766 comm="rhsmcertd-worke" name="bash" dev="dm-1" ino=1179651 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.269:310): avc:  denied  { execute_no_trans } for  pid=8766 comm="rhsmcertd-worke" path="/bin/bash" dev="dm-1" ino=1179651 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.270:311): avc:  denied  { getattr } for  pid=8766 comm="sh" path="/bin/bash" dev="dm-1" ino=1179651 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.285:312): avc:  denied  { getattr } for  pid=8772 comm="virt-what" path="/usr/sbin/dmidecode" dev="dm-1" ino=150349 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:dmidecode_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.285:313): avc:  denied  { execute } for  pid=8772 comm="virt-what" name="dmidecode" dev="dm-1" ino=150349 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:dmidecode_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.285:314): avc:  denied  { read } for  pid=8772 comm="virt-what" name="dmidecode" dev="dm-1" ino=150349 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:dmidecode_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.286:315): avc:  denied  { open } for  pid=8773 comm="virt-what" name="dmidecode" dev="dm-1" ino=150349 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:dmidecode_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.286:315): avc:  denied  { execute_no_trans } for  pid=8773 comm="virt-what" path="/usr/sbin/dmidecode" dev="dm-1" ino=150349 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:dmidecode_exec_t:s0 tclass=file
type=AVC msg=audit(1347962853.286:316): avc:  denied  { read } for  pid=8773 comm="dmidecode" name="mem" dev="devtmpfs" ino=1027 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:memory_device_t:s0 tclass=chr_file
type=AVC msg=audit(1347962853.286:316): avc:  denied  { open } for  pid=8773 comm="dmidecode" name="mem" dev="devtmpfs" ino=1027 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:memory_device_t:s0 tclass=chr_file
type=AVC msg=audit(1347962853.286:316): avc:  denied  { sys_rawio } for  pid=8773 comm="dmidecode" capability=17  scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:system_r:rhsmcertd_t:s0 tclass=capability
type=AVC msg=audit(1347962853.631:317): avc:  denied  { name_connect } for  pid=8763 comm="rhsmcertd-worke" dest=443 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:http_port_t:s0 tclass=tcp_socket
type=AVC msg=audit(1347962854.759:318): avc:  denied  { signull } for  pid=8815 comm="rhsmcertd-worke" scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=unconfined_u:system_r:rpm_t:s0-s0:c0.c1023 tclass=process
type=AVC msg=audit(1347962854.759:319): avc:  denied  { signull } for  pid=8815 comm="rhsmcertd-worke" scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=unconfined_u:system_r:initrc_t:s0 tclass=process
Comment 1 Devan Goodwin 2012-10-26 15:21:10 EDT

*** This bug has been marked as a duplicate of bug 870542 ***

Note You need to log in before you can comment on or make changes to this bug.