Bug 858249 - 3.0.7 WPF crashes on trying to upgrade RHEV-H
3.0.7 WPF crashes on trying to upgrade RHEV-H
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Doron Fediuck
Haim
integration
: Reopened
: 860619 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 08:36 EDT by Meng Liang
Modified: 2016-04-26 10:58 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 03:24:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error page (29.52 KB, image/png)
2012-09-18 08:39 EDT, Meng Liang
no flags Details
log (19.35 KB, application/octet-stream)
2012-09-18 08:39 EDT, Meng Liang
no flags Details

  None (edit)
Description Meng Liang 2012-09-18 08:36:41 EDT
Description of problem:
RHEVM crashed when upgraded rhevh on it

Version-Release number of selected component (if applicable):
rhevm-3.1.0-16.el6ev.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install rhevm-3.1.0-16.el6ev.noarch.rpm
2. upgrade rhevh6.2 to rhev-hypervisor6-6.3-20120913.0.el6_3 via RHEVM
3. This could not be fixed by re-login or restart RHEVM

Actual results:
RHEVM jump to error page as attached figure shows. 
Log 'more information' was provided. see attached as well.

Expected results:
rhevh should be upgrade successfully without error message

Additional info:
Comment 1 Meng Liang 2012-09-18 08:39:07 EDT
Created attachment 614000 [details]
screenshot of error page
Comment 2 Meng Liang 2012-09-18 08:39:48 EDT
Created attachment 614002 [details]
log
Comment 5 Itamar Heim 2012-09-19 04:55:44 EDT
exception from log:
Startup URI: http://rhevm-ic-104-240.rhevm.englab.nay.redhat.com:8080/RHEVManager/WPFClient.xbap
Application Identity: http://rhevm-ic-104-240.rhevm.englab.nay.redhat.com:8080/RHEVManager/WPFClient.xbap#WPFClient.xbap, Version=4.6.0.52, Culture=neutral, PublicKeyToken=6673332c7e4bb4b7, processorArchitecture=msil/WPFClient.exe, Version=4.6.0.52, Culture=neutral, PublicKeyToken=6673332c7e4bb4b7, processorArchitecture=msil, type=win32

System.ArgumentException: Version string portion was too short or too long.
   at System.Version.VersionResult.SetFailure(ParseFailureKind failure, String argument)
   at System.Version.TryParseVersion(String version, VersionResult& result)
   at System.Version.Parse(String input)
   at System.Version..ctor(String version)
   at org.ovirt.engine.ui.uicommon.models.hosts.HostGeneralModel.GetVersionFromOS(String os)
   at org.ovirt.engine.ui.uicommon.models.hosts.HostGeneralModel.Install()
   at org.ovirt.engine.ui.uicommon.models.hosts.HostGeneralModel.ExecuteCommand(UICommand command)
   at org.ovirt.engine.ui.uicommon.UICommand.Execute(Object parameter)
Comment 8 Mike Burns 2012-09-19 12:24:05 EDT

*** This bug has been marked as a duplicate of bug 853092 ***
Comment 16 Doron Fediuck 2012-09-23 08:33:19 EDT
Thanks for the information.
I was able to reproduce and see this happens due to the addition of the rhev31
part in the version, and it may only happen on WPF code.
Can you please verify this does not happen in rhevm 3.1?
Comment 18 Doron Fediuck 2012-09-24 03:24:27 EDT
Closing this BZ, as the rhev31 version is not relevant for 3.0 users.
So this scenario is unsupported.
Comment 19 Yaniv Kaul 2012-09-26 13:04:41 EDT
*** Bug 860619 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.