This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 858253 - Member search fails in user group detail page.
Member search fails in user group detail page.
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity medium
: beta2
: ---
Assigned To: Scott Seago
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 08:40 EDT by Aziza Karol
Modified: 2012-12-04 10:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Searching for members within user groups, an error displayed: "Unknown action: The action 'filter_members' could not be found for UserGroupsController" This update fixes the error. Searching within user groups now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:20:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
member search (11.50 KB, image/png)
2012-09-18 08:42 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-09-18 08:40:57 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1.Navigate to Administer->user->user groups.
2.create a user group "usr_grp_az" and add members to this group..
3.click on usr_grp_az.
2.Do a search on members.
  

Actual results:
The action 'filter_members' could not be found for UserGroupsController is displayed in UI. see attached screenshot.

Expected results:
search should work.
Also the permission search seems to be disabled.

Additional info:
rpm  -qa | grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch



rails.log:
AbstractController::ActionNotFound (The action 'filter_members' could not be found for UserGroupsController):
 
Rendered /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_dispatch/middleware/templates/rescues/unknown_action.erb within rescues/layout (1.1ms)
Comment 1 Aziza Karol 2012-09-18 08:42:21 EDT
Created attachment 614012 [details]
member search
Comment 3 Scott Seago 2012-09-19 13:39:26 EDT
pushed to master and 1.1:
master: ea65ef813d04d62bb4bfa0fdefd019e01c684cec
1.1:    b70b9cddcf04343069eee96b8e1c20f4d02effee
Comment 5 Aziza Karol 2012-09-25 02:41:44 EDT
Member search works in user group detail page.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 7 errata-xmlrpc 2012-12-04 10:20:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.