This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 858257 - groovy: Licensing issues
groovy: Licensing issues
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: groovy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 877048
  Show dependency treegraph
 
Reported: 2012-09-18 09:13 EDT by Mikolaj Izdebski
Modified: 2013-07-25 00:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.8.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 877048 (view as bug list)
Environment:
Last Closed: 2013-07-25 00:03:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-09-18 09:13:42 EDT
Description of problem:
The License tag of groovy package states that the license is ASL 2.0 only, but the source includes many different files under different licenses. The license tag should state ASL 2.0 and BSD and CPL.

Moreover, not all required license files are installed or even present in the SRPM. According to packaging guidelines license files should be installed in all subpackages. This means that LICENSE.txt and NOTICE.txt should be installed with javadoc package.

Because some parts are licensed under CPL license, the whole copy of CPL must be included in SRPM. Quoting from the text of CPL: "When the Program is made available in source code form [...] a copy of this Agreement must be included with each copy of the Program". If it will be included in the SRPM then it should also be installed (with both main package and javadoc subpackage).

One of files under BSD: groovy-1.8.7/src/main/org/codehaus/groovy/jsr223/GroovyScriptEngineImpl.java
The file under CPL: groovy-1.8.7/src/main/org/codehaus/groovy/classgen/ClassCompletionVerifier.java

Version-Release number of selected component (if applicable):
1.8.7-1

To summarize things that need to be done:
 1. include CPL license text in SRPM
 2. set license tag to "ASL 2.0 and BSD and CPL"
 3. add CPL to %doc in main package
 4. add ASL, CPL and NOTICE.txt to javadoc package as %doc
Comment 1 Fedora Admin XMLRPC Client 2012-10-04 08:52:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Mikolaj Izdebski 2012-11-22 12:27:35 EST
Any progress on that?

I'm adding block on FE-LEGAL because this package violates upstream licensing terms. It violates terms of Common Public License Version 1.0 by not providing license text ("a copy of this Agreement must be included with each copy of the Program").
Comment 3 Tom "spot" Callaway 2012-11-27 13:08:28 EST
Fixed in groovy-1.8.8-1.fc19.
Comment 4 Mikolaj Izdebski 2013-01-28 05:37:33 EST
I will fix this bug in Fedora 18 too.
Comment 5 Mikolaj Izdebski 2013-01-28 05:39:32 EST
Fixed in groovy-1.8.7-2
Comment 6 Fedora Update System 2013-01-30 03:45:35 EST
groovy-1.8.7-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/groovy-1.8.7-2.fc18
Comment 7 Fedora Update System 2013-02-01 12:08:25 EST
Package groovy-1.8.7-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing groovy-1.8.7-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1779/groovy-1.8.7-2.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-03-12 19:26:59 EDT
groovy-1.8.7-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Mikolaj Izdebski 2013-06-06 12:23:34 EDT
I am reopening the bug as licensing issues weren't fully resolved yet.

1) Some files are under public domain, but the license tag doesn't include 'Public Domain'

2) License text of ASL 2.0 is not provided, which is a violation of point 4 a) of the license.
Comment 10 Mikolaj Izdebski 2013-06-06 12:30:24 EDT
Fixed in groovy-1.8.9-2
Comment 11 Fedora Update System 2013-06-13 06:16:10 EDT
groovy-1.8.9-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/groovy-1.8.9-2.fc19
Comment 12 Fedora Update System 2013-07-23 23:38:13 EDT
groovy-1.8.9-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Mikolaj Izdebski 2013-07-25 00:03:35 EDT
I believe that this bug is fixed in groovy-1.8.9-2,
which is available in updates for Fedora 19, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=424979

This bug was fixed in the next release of Fedora, and is not planned
to be fixed in the release it was filed against.  If you want this bug
to be fixed in updates for Fedora 18, please say so in a comment.
Otherwise you can update to the newer release of Fedora to get the fix.

Note You need to log in before you can comment on or make changes to this bug.