Bug 858289 - Rename subscription-manager.desktop file
Rename subscription-manager.desktop file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993
  Show dependency treegraph
 
Reported: 2012-09-18 11:02 EDT by Matt Reid
Modified: 2013-02-21 03:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:56:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Icons before name change (135.66 KB, image/png)
2012-12-10 10:34 EST, Matt Reid
no flags Details
Icons after name change (367.94 KB, image/png)
2012-12-10 10:39 EST, Matt Reid
no flags Details
renderings of subscription-manager icon on rhel64 (1.30 MB, image/png)
2012-12-10 13:05 EST, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-09-18 11:02:34 EDT
Description of problem:
This is only noticeable in Fedora at this point, but since the command to run Subscription Manager is subscription-manager-gui and our icon and .desktop file are called subscription-manager, GNOME can get confused and fallback to using way smaller sizes than it should. This includes GNOME Shell ignoring our 48px icon and using a smaller one that gets super pixel-y, which it also uses in place of the 256px alt-tab icon. 

Renaming subscription-manager.desktop to subscription-manager-gui.desktop results in GNOME paying attention to our 48px icon, and using a larger icon for the 256px alt-tab instead of a 16/24/32 or whatever it was, blown way up to 256.

The other fix would be to change something in the code, I didn't quite follow what it was, but I can follow up with Ray again if anyone is curious.

Are there any other implications to doing this? Shouldn't break anything, right?
Comment 1 Bryan Kearney 2012-10-08 15:05:04 EDT
fixed in master at f186b5dc614d2d0d00158d6e9952f4b96eacca20
Comment 5 Matt Reid 2012-12-10 10:34:43 EST
Created attachment 660923 [details]
Icons before name change
Comment 6 Matt Reid 2012-12-10 10:39:25 EST
Created attachment 660925 [details]
Icons after name change

My vm is a bit out of date, not sure if the alt tab icon would use a png (and render properly) instead of an svg (and have that gray bar sticking out of the icon) if it was newer, or if I hadn't mucked around with the settings trying to recreate the pixelated icons after they had been fixed on my vm.
Comment 7 John Sefler 2012-12-10 13:05:38 EST
Created attachment 661002 [details]
renderings of subscription-manager icon on rhel64

Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.1.11-1.el6.x86_64

[root@jsefler-6 ~]# rpm -ql subscription-manager-gui | grep desktop
/etc/xdg/autostart/rhsm-icon.desktop
/usr/share/applications/subscription-manager-gui.desktop
                                            ^^^^
VERIFIED THAT subscription-manager.desktop WAS RENAMED TO subscription-manager-gui.desktop

Using attachment 660925 [details] from mreid to verify that the name change was helpful to fedora.

SEE the attachment for "renderings of subscription-manager icon" on rhel64 which includes the subscription-manager-gui.desktop rendered using Alt-Tab.

In my opionon, these RHEL64 renderings are not pixel-y.

Moving to VERIFIED.
Comment 11 errata-xmlrpc 2013-02-21 03:56:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.