Bug 858312 - [abrt] system-config-printer-1.3.11-3.fc18: system-config-printer.py:89:<module>:ImportError: No module named firewall
[abrt] system-config-printer-1.3.11-3.fc18: system-config-printer.py:89:<modu...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:897151ead0b9753a2b938578ed8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 11:44 EDT by kevin martin
Modified: 2012-12-11 19:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 12:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (114 bytes, text/plain)
2012-09-18 11:44 EDT, kevin martin
no flags Details

  None (edit)
Description kevin martin 2012-09-18 11:44:15 EDT
Description of problem:
just trying to open system-config-printer

Version-Release number of selected component:
system-config-printer-1.3.11-3.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64

backtrace:
:system-config-printer.py:89:<module>:ImportError: No module named firewall
:
:Traceback (most recent call last):
:  File "/usr/share/system-config-printer/system-config-printer.py", line 89, in <module>
:    import firewall
:ImportError: No module named firewall
:
:Local variables in innermost frame:
:userdefault: <module 'userdefault' from '/usr/share/system-config-printer/userdefault.pyc'>
:locale: <module 'locale' from '/usr/lib64/python2.7/locale.pyc'>
:show_HTTP_Error: <function show_HTTP_Error at 0x2d61578>
:urllib: <module 'urllib' from '/usr/lib64/python2.7/urllib.pyc'>
:get_debugging: <function get_debugging at 0x2ce4c08>
:show_IPP_Error: <function show_IPP_Error at 0x2d61500>
:authconn: <module 'authconn' from '/usr/share/system-config-printer/authconn.pyc'>
:set_debugging: <function set_debugging at 0x2ce4c80>
:gtk_label_autowrap: <module 'gtk_label_autowrap' from '/usr/share/system-config-printer/gtk_label_autowrap.pyc'>
:statereason: <module 'statereason' from '/usr/share/system-config-printer/statereason.pyc'>
:GInitiallyUnowned: <class 'gtk.__main__.GInitiallyUnowned'>
:GPollableOutputStream: <class 'gio.__main__.GPollableOutputStream'>
:cups: <module 'cups' from '/usr/lib64/python2.7/site-packages/cups.so'>
:ToolbarSearchEntry: <class 'ToolbarSearchEntry.ToolbarSearchEntry'>
:fatalException: <function fatalException at 0x2ce4cf8>
:monitor: <module 'monitor' from '/usr/share/system-config-printer/monitor.pyc'>
:show_error_dialog: <function show_error_dialog at 0x2d61488>
:show_info_dialog: <function show_info_dialog at 0x2d61410>
:gtk: <module 'gtk' from '/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.pyc'>
:gettext: <module 'gettext' from '/usr/lib64/python2.7/gettext.pyc'>
:__package__: None
:re: <module 're' from '/usr/lib64/python2.7/re.pyc'>
:HIG: <module 'HIG' from '/usr/share/system-config-printer/HIG.pyc'>
:config: <module 'config' from '/usr/share/system-config-printer/config.pyc'>
:__doc__: None
:nonfatalException: <function nonfatalException at 0x2ce4d70>
:__builtins__: <module '__builtin__' (built-in)>
:__file__: '/usr/share/system-config-printer/system-config-printer.py'
:ServerSettings: <class 'serversettings.ServerSettings'>
:cupshelpers: <module 'cupshelpers' from '/usr/lib/python2.7/site-packages/cupshelpers/__init__.pyc'>
:show_help: <function show_help at 0x2aef050>
:GPollableInputStream: <class 'gio.__main__.GPollableInputStream'>
:installpackage: <module 'installpackage' from '/usr/share/system-config-printer/installpackage.pyc'>
:SearchCriterion: <class SearchCriterion.SearchCriterion at 0x2e918d8>
:GtkGUI: <class 'gui.GtkGUI'>
:__name__: '__main__'
:debugprint: <function debugprint at 0x2ce4b18>
:_: <function gettext at 0x279e1b8>
:sys: <module 'sys' (built-in)>
:jobviewer: <module 'jobviewer' from '/usr/share/system-config-printer/jobviewer.pyc'>
:show_uri: <function show_uri at 0x2860938>
:thread: <module 'thread' (built-in)>
:errordialogs: <module 'errordialogs' from '/usr/share/system-config-printer/errordialogs.pyc'>
:dbus: <module 'dbus' from '/usr/lib/python2.7/site-packages/dbus/__init__.pyc'>
:traceback: <module 'traceback' from '/usr/lib64/python2.7/traceback.pyc'>
:GFileDescriptorBased: <class 'gio.__main__.GFileDescriptorBased'>
:show_dialog: <function show_dialog at 0x2d61398>
:time: <module 'time' from '/usr/lib64/python2.7/lib-dynload/timemodule.so'>
:gobject: <module 'gobject' from '/usr/lib64/python2.7/site-packages/gobject/__init__.pyc'>
:os: <module 'os' from '/usr/lib64/python2.7/os.pyc'>
:troubleshoot: <module 'troubleshoot' from '/usr/share/system-config-printer/troubleshoot/__init__.pyc'>
Comment 1 kevin martin 2012-09-18 11:44:18 EDT
Created attachment 614050 [details]
File: core_backtrace
Comment 2 Jiri Popelka 2012-09-18 12:44:59 EDT
This will be fixed with system-config-printer-1.3.11-4.fc18.
Because system-config-printer-1.3.11-3.fc18 has been only in testing I'm closing this ticket.
Comment 4 Fedora Update System 2012-09-21 08:30:25 EDT
system-config-printer-1.3.11-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-13540/system-config-printer-1.3.11-5.fc18
Comment 5 Fedora Update System 2012-10-09 05:47:23 EDT
system-config-printer-1.3.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.12-1.fc18
Comment 6 Fedora Update System 2012-12-11 19:29:15 EST
system-config-printer-1.3.12-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.