Bug 858340 - dynamic DNS updating does not work for IPv6
dynamic DNS updating does not work for IPv6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 13:33 EDT by Gene Czarcinski
Modified: 2013-05-07 10:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-07 10:45:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2012-09-18 13:33:18 EDT
While dynamic DNS updating works for IPv4, it does not work for IPv6 because
NetworkManager does not send the client-host's name in its dhcp request.

I have tested this with dnsmasq and am setting up testing to see if the same
situation occurs with dhcpd-v6/named.

My test was to run wireshark to capture the packets and, while running
NetworkManager and then enable an interface with a IPv6 network.

I then stopped NetowrkManager and used the "ifup eth0" network script with a
slight modification to ifup-eth in the dhclient commandline to change "-H" to
"-F".  Worked fine!  There they were ... the fqdn specification in the dhcpv6
packets.

Note ... the lease file showed a lot of additional entries when things work.  I
do not know if just doing a "send fqdn.fqdn name;" will be sufficent.

This testing was done on Fedora 17.
------------------------------------------------
I have repeated the test except that I installed and configured bind and dhcp (both dhcpd and dhcpd6 servers) on the server instead of dnsmasq.  The client test remained the same and the results remained the same.

This has been reported upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=684242

Suggestion: rather than creating a dhcpd6 and dhcpd conf files, do a small modification to the code starting dhclient.  For IPv4, use "-H" on the command line and for IPv6 use "-F" ... this seems to work well.

I looked at the code and I am sure there are a number of folks who understand it but it was a bit more than I want to chew.
Comment 1 Gene Czarcinski 2013-01-25 07:39:53 EST
This problem has been fixed upstream.  I know because I did the update and am running it (tarball created from git 20121130).  Wheat does it take to get a more recent version?

Note You need to log in before you can comment on or make changes to this bug.