Bug 858356 - FTBFS: Build failure on PPC64 due to circular depency
FTBFS: Build failure on PPC64 due to circular depency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hornetq (Show other bugs)
18
ppc64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 14:54 EDT by Gustavo Luiz Duarte
Modified: 2012-10-12 17:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 17:11:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo Luiz Duarte 2012-09-18 14:54:35 EDT
Description of problem:

Hornetq fails to build on ppc64 with the following error message during mock setup:

Error: Package: jboss-jts-4.16.2-8.fc18.noarch (build)
           Requires: ironjacamar
Error: Package: jboss-jts-4.16.2-8.fc18.noarch (build)
           Requires: hornetq
Error: Package: jboss-jts-4.16.2-8.fc18.noarch (build)
           Requires: java-service-wrapper
Error: Package: jboss-jts-4.16.2-8.fc18.noarch (build)
           Requires: jacorb


Version-Release number of selected component (if applicable):
hornetq-2.2.13-4.fc18

How reproducible:
Always


Steps to Reproduce:
1. ppc-koji build --scratch f18 hornetq-2.2.13-4.fc18.src.rpm
2.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=709051

Expected results:


Additional info:
Comment 1 Marek Goldmann 2012-09-19 02:54:34 EDT
Hi Gustavo,

In the initial import of jboss-jts we haven't had hornetq support enabled, therefore it wasn't required. Since version 4.16.2-4 the HornetQ support is now enabled.

The solution would be to build jboss-jts < 4.16.2-4, build hornetq and rebuild jboss-jts. Is it possible?

This issue doesn't exist in the main koji, since packages were build in proper order.
Comment 2 Gustavo Luiz Duarte 2012-09-19 13:51:42 EDT
Thanks Marek!

My scratch build of jboss-jts-4.16.2-3.fc18 finished successful:
https://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=711625

David, could you fire up a build of jboss-jts-4.16.2-3.fc18 ? I suppose after that koji-shadow would catch up with latest versions of hornetq and jboss-jts, right?
Comment 3 Karsten Hopp 2012-10-12 17:11:17 EDT
I took care of that and built hornetq-2.2.13-4.fc18 (and java-service-wrapper, which had an excludearch but is a requirement of jboss-jts)

Note You need to log in before you can comment on or make changes to this bug.