Bug 858386 - modcluster: Encode XML-unsafe characters from user input as XML entities
modcluster: Encode XML-unsafe characters from user input as XML entities
Status: CLOSED DUPLICATE of bug 855112
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: clustermon (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jan Pokorný
Cluster QE
:
Depends On:
Blocks: 855121
  Show dependency treegraph
 
Reported: 2012-09-18 16:24 EDT by Jan Pokorný
Modified: 2014-03-27 12:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 855112
Environment:
Last Closed: 2014-03-27 12:43:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-09-18 16:24:10 EDT
+++ This bug was initially created as a clone of Bug #855112 +++

In connection to case discussed in the public cluster ML [1], we need
to make sure the user input that makes its way into XML (either as
cluster.conf or XML-formatted requests towards ricci) is XML-ready.
That is, the "unsafe" characters are encoded as XML entities.

More generally, we need to make sure XML entities are handled
correctly in each step of processing in following chain:

client (ccs, luci) -- ricci -- ricci-worker -- modcluster

Otherwise, such requests have no effect and unfortunately, neither
ricci provides a sensible diagnostics about this.  Example of such
input is the password for the initial authentization against ricci.

[1] https://www.redhat.com/archives/linux-cluster/2012-August/msg00135.html
Comment 1 RHEL Product and Program Management 2012-09-18 16:29:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Fabio Massimo Di Nitto 2014-03-27 12:43:37 EDT

*** This bug has been marked as a duplicate of bug 855112 ***

Note You need to log in before you can comment on or make changes to this bug.