Bug 858388 - Update to latest upstream for marvell wifi updates
Update to latest upstream for marvell wifi updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 16:29 EDT by Daniel Drake
Modified: 2012-12-20 10:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:14:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file update (812 bytes, patch)
2012-09-18 16:29 EDT, Daniel Drake
no flags Details | Diff

  None (edit)
Description Daniel Drake 2012-09-18 16:29:02 EDT
Created attachment 614114 [details]
spec file update

Thanks for splitting libertas subpackages in bug #853198.

While that was happening, we've updated the firmware versions in question in linux-firmware upstream.

Please could we update the package to the latest upstream?

Here is a new tarball:
http://dev.laptop.org/~dsd/20120918/linux-firmware-20120909.tar.gz

Generated with:
git archive --format=tar --prefix=linux-firmware-a707c25/ HEAD | gzip > linux-firmware-20120909.tar.gz

And the .spec file diff is trivial, attached.

I'm happy to push/build this if you prefer.
Comment 1 Josh Boyer 2012-09-19 08:23:42 EDT
I can't update this yet.  Larry Finger submitted some newer firmware for some of the rtl8712u devices back in July and has since found it to be somewhat broken on several devices.  He sent a revert patch upstream, but it hasn't been integrated yet.

I'll see if I can find Ben and ask him if/when that patch might go in.
Comment 2 Daniel Drake 2012-09-24 10:53:04 EDT
Hmm, I can see how that is a pain.

Are you referring to this commit as the bad one?

r8712u: Update to latest firmware

It already seems to be included in the latest F18 version (because the snapshot was taken of commit 7560108 which is a later commit).



Or maybe this newer one?

rtlwifi/rtl8723e: Add firmware for new driver

If so, would you consider reverting that on a Fedora level? git revert; git format-patch generates a 26kb patch (21kb gzipped) which can be applied with git-apply (new temporary buildrequires would be needed).
Comment 3 Josh Boyer 2012-09-24 15:38:39 EDT
(In reply to comment #2)
> Or maybe this newer one?
> 
> rtlwifi/rtl8723e: Add firmware for new driver

Believe that was the one (though it might have been both).

> If so, would you consider reverting that on a Fedora level? git revert; git
> format-patch generates a 26kb patch (21kb gzipped) which can be applied with
> git-apply (new temporary buildrequires would be needed).

Ben reverted it upstream.  Just waiting for him to push it out.  Should be tomorrow-ish, and then I'll do an update.
Comment 4 Josh Boyer 2012-09-25 08:36:59 EDT
Updated in git.  Builds started.  Will file an f18 update after the build completes.
Comment 5 Fedora Update System 2012-09-25 08:52:52 EDT
linux-firmware-20120925-0.1.git236367d.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/linux-firmware-20120925-0.1.git236367d.fc18
Comment 6 Fedora Update System 2012-09-25 11:57:22 EDT
Package linux-firmware-20120925-0.1.git236367d.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20120925-0.1.git236367d.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14754/linux-firmware-20120925-0.1.git236367d.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 10:14:16 EST
linux-firmware-20120925-0.1.git236367d.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.