Bug 858427 - Need better practise on (not) editing /usr/share/java/conf/core-site.xml
Need better practise on (not) editing /usr/share/java/conf/core-site.xml
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
2.0
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Divya
SATHEESARAN
:
Depends On: 840508
Blocks: 854541
  Show dependency treegraph
 
Reported: 2012-09-18 18:21 EDT by Scott Haines
Modified: 2015-04-10 03:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 840508
Environment:
Last Closed: 2015-04-10 03:15:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Haines 2012-09-18 18:21:16 EDT
+++ This bug was initially created as a clone of Bug #840508 +++

It is extremely rare that configuration files under /usr need to be edited. Page 152 (http://docs.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html-single/Administration_Guide/index.html#id3047004) tells to make changes in /usr/share/java/conf/core-site.xml. I am wondering if there is not a better suitable file under /etc that can be used to overload the configuration. (Ah, page 153 tells to create a sym-link to the configuration directory. Maybe it's better practise to not link, but copy the configuration?)

--- Additional comment from vshankar@redhat.com on 2012-07-30 06:18:01 EDT ---

AJ mentioned that /usr/share/java is where jars get installed. You're right, that need not be the path for the configuration file. If /etc makes more sense for configuration files, I'm okay in moving core-site.xml somewhere there.

Regarding the sym-link thing, that's how we wanted it with upstream GlusterFS. If it's a good practice (RHS?) in copying the file over, then docs need to be updated.

--- Additional comment from divya@redhat.com on 2012-07-31 01:44:34 EDT ---

Niels,

Based on my discussion with VS and Venky, it was decided to move core-site.xml file to /var/lib/glusterd/. We will request AJ to move it and then update the doc.

Kindly confirm if copying the configuration file is the best practice instead of linking. Based on your confirmation, I will update the doc.

Regards,
Divya

--- Additional comment from ndevos@redhat.com on 2012-08-03 05:55:46 EDT ---

Hi Divya,

yes, copying a file from /usr/... to /var/lib/.. is fine. Contents under /usr should not be edited by administrators, /var/lib is definitely a better place for that.

It is possible that the original file under /usr/... is kept, and the administrator manually copies the file to /var/lib/... Automatically would be good too, but I don't know how practical that is.

Thanks,
Niels

--- Additional comment from vshankar@redhat.com on 2012-08-09 14:13:58 EDT ---

lets keep it in /var/lib/glusterd/glusterfs-hadoop/

administrator can manually copy the conf from this directory to whatever his $HADOOP_HOME is.

AJ, the spec file would need to change to drop the conf in the above mentioned directory.

--- Additional comment from divya@redhat.com on 2012-09-05 05:54:45 EDT ---

As suggested, I have changed instructions to copy files to respective location instead of creating symbolic links. 

The updated documentation is available at: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/sect-Administration_Guide-GlusterFS_Client-CIFS.html#id1257909

Cloning this bug for Release Engineering to move the file to /var/lib/glusterd/glusterfs-hadoop/.
Comment 2 Divya 2012-10-03 06:28:19 EDT
I have changed instructions to copy files to respective location instead of creating symbolic links. 

The updated documentation is available at: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/sect-Administration_Guide-GlusterFS_Client-CIFS.html#id1257909

Cloned this bug for Release Engineering to move the file to /var/lib/glusterd/glusterfs-hadoop/.
Comment 3 SATHEESARAN 2012-10-11 08:26:32 EDT
Since this bug is blocked by 854541, it could not be moved to VERIFIED state
Comment 4 SATHEESARAN 2012-11-19 04:17:13 EST
First part of this bug is fixed - [ Copying instead of creating symbolic link] - is verified, but the latter part of moving the file /usr/share/java/conf/core-site.xml to /var/lib/glusterd/glusterfs-hadoop/core-site.xml will tracked seperately, as it is not yet implemented, in a new bug as discussed with Divya. So moving this bug to VERIFIED state

Note You need to log in before you can comment on or make changes to this bug.