Bug 858432 - Avoid logs related to printers from samba
Avoid logs related to printers from samba
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jose A. Rivera
Sudhir D
:
Depends On: 844188
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 18:22 EDT by Scott Haines
Modified: 2015-01-22 10:29 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 844188
Environment:
Last Closed: 2013-09-23 18:39:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Ujjwala 2013-08-01 03:42:46 EDT
CUPS server messages are not seen in log.smbd

1. But I see following messages:

[2013/08/01 06:21:14,  0] param/loadparm.c:7969(lp_do_parameter)
  Ignoring unknown parameter "show add printers wizard"
[2013/08/01 06:21:14,  0] param/loadparm.c:6180(lp_bool)
  lp_bool(no    # Improves large file sequential I/O): value is not boolean!
[2013/08/01 06:21:14,  0] param/loadparm.c:6180(lp_bool)
  lp_bool(no            # Improves small file operations): value is not boolean!


"# Improves large file sequential I/O " is the comment added to kernel oplocks = no
"# Improves small file operations" is the comment added to stat cache = no

2. No comments for the following new entries in the smb.conf file
        load printers = no
        disable spoolss = yes
        show add printers wizard = no
        printing = bsd
Comment 3 Susant Kumar Palai 2013-08-01 05:01:54 EDT
Jose ,
    
Small change.
   
1st# "show add printers wizard"  should be --->"show add printer wizard"(remove the 's' from the printers)

2nd# What I observed is we can't comment at the end of parameters 
e.g kernel oplocks = no #Improves large file sequential  

    We should comment from the beginning of the line. In this case just before the parameter we should give the comments like :


#Improves large file sequential
kernel oplocks = no
Comment 5 Christopher R. Hertel 2013-08-05 14:55:31 EDT
Some quick research shows that the formatting I provided in BZ 844188 is incorrect.  Samba does not allow trailing comments in the smb.conf file.  The comment characters (';' and '#') must be the first (non-whitespace) thing on the line, otherwise the comment is seen as being part of the parameter value.  This is because both ';' and '#' are legal within such values.  Moving the comments to their own separate lines should solve the problem encountered by QE.
Comment 6 Ujjwala 2013-08-06 01:34:35 EDT
Verified on Samba-glusterfs-3.6.9-156.2 build. Looks fine.
Comment 8 Scott Haines 2013-09-23 18:39:13 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 9 Scott Haines 2013-09-23 18:43:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.