Bug 858469 - Avoid volume status for getting statedumps in sosreport
Avoid volume status for getting statedumps in sosreport
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Raghavendra Bhat
Sachidananda Urs
:
Depends On: 851175
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 18:27 EDT by Scott Haines
Modified: 2015-01-22 10:29 EST (History)
9 users (show)

See Also:
Fixed In Version: sos-2.2_17.2.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 851175
Environment:
Last Closed: 2014-04-23 19:06:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Amar Tumballi 2012-10-11 09:18:46 EDT
sos-2.2.17.1rhs is built with these changes
Comment 3 Bryn M. Reeves 2012-10-11 10:07:38 EDT
That's package sos-2.2-17.1.el6rhs right?

http://download.devel.redhat.com/brewroot/packages/sos/2.2/17.el6rhs.1/
http://download.devel.redhat.com/brewroot/packages/sos/2.2/17.1.el6rhs/

Note that the other NVR sorts older than the current sos package for RHS - that is currently sos-2.2-17.el6_2.3:

# rpm -Uvh sos-2.2-17.el6_2.3.noarch.rpm 
Preparing...                ########################################### [100%]
   1:sos                    ########################################### [100%]

# rpm -Uvh sos-2.2-17.el6rhs.1.noarch.rpm 
Preparing...                ########################################### [100%]
	package sos-2.2-17.el6_2.3.noarch (which is newer than sos-2.2-17.el6rhs.1.noarch) is already installed

This breaks the upgrade path from existing released packages.

Packages need to comply with the release numbering for z-stream builds so that the new el6rhs packages sort newer than the ones that they are replacing (it's also pretty confusing to have numbers go backward like that in the RPM changelog).

There is a later commit (ff0c81f) on rhs-2.0-rhel-6 - this has an NVR of sos-2.2-17.1.el6rhs which sorts correctly due to the 17.1 but it still looks a little odd following on from 2.2-17.el6_2.3.
Comment 4 Sachidananda Urs 2013-01-08 01:15:38 EST
Tested with new sosreport package: http://download.devel.redhat.com/brewroot/packages/sos/2.2/17.2.el6rhs/noarch/sos-2.2-17.2.el6rhs.noarch.rpm 

The above issue reported by BMR is resolved by adding .2 to the package name.
Comment 5 Scott Haines 2014-04-23 19:06:28 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.