Bug 858489 - BUG: unable to handle kernel NULL pointer dereference at 0000000000000014 EIP: svc_destroy
BUG: unable to handle kernel NULL pointer dereference at 0000000000000014 EIP...
Status: CLOSED DUPLICATE of bug 848867
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: nfs-maint
Fedora Extras Quality Assurance
:
: 863764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 18:30 EDT by Hin-Tak Leung
Modified: 2012-12-05 08:38 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 08:38:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2012-09-18 18:30:10 EDT
Description of problem:

[   44.416372] svc: failed to register nfsdv2 RPC service (errno 5).
[   44.416418] svc: failed to register nfsaclv2 RPC service (errno 5).
[   44.416673] nfsd: last server has exited, flushing export cache
[   44.416709] BUG: unable to handle kernel NULL pointer dereference at 0000000000000014
[   44.416880] IP: [<ffffffffa01ee1ae>] svc_destroy+0x1e/0x140 [sunrpc]
[   44.417014] PGD 0 
[   44.417020] Oops: 0000 [#1] SMP 
[   44.417020] CPU 0 
[   44.417020] Modules linked in: ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc xt_LOG xt_physdev nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack arc4 rtl8187 eeprom_93cx6 mac80211 cfg80211 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep joydev snd_pcm snd_page_alloc snd_timer snd soundcore k8temp r592 edac_core edac_mce_amd memstick sp5100_tco i2c_piix4 r8169 mii shpchp toshiba_acpi sparse_keymap rfkill wmi vhost_net tun macvtap macvlan kvm_amd nfsd nfs_acl kvm ecryptfs auth_rpcgss sha256_generic lockd encrypted_keys sunrpc trusted tpm uinput tpm_bios binfmt_misc ata_generic pata_acpi firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t pata_atiixp video radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
[   44.417020] 
[   44.417020] Pid: 810, comm: rpc.nfsd Not tainted 3.5.3-1.fc17.x86_64 #1 TOSHIBA Satellite Pro A210/SB600
[   44.417020] RIP: 0010:[<ffffffffa01ee1ae>]  [<ffffffffa01ee1ae>] svc_destroy+0x1e/0x140 [sunrpc]
[   44.417020] RSP: 0018:ffff880071857e28  EFLAGS: 00010246
[   44.417020] RAX: 00000000fffffffb RBX: 0000000000000000 RCX: 0000000000000100
[   44.417020] RDX: 0000000000000100 RSI: 000000005058f1f1 RDI: 0000000000000000
[   44.417020] RBP: ffff880071857e38 R08: ffff8800743b3000 R09: 0000000000000000
[   44.417020] R10: 0000000000000000 R11: 0000000000040000 R12: 0000000000000002
[   44.417020] R13: 0000000000000004 R14: ffff880071857f50 R15: 00007fa31f85d2ae
[   44.417020] FS:  00007fa31f7f3740(0000) GS:ffff880077c00000(0000) knlGS:0000000000000000
[   44.417020] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[   44.417020] CR2: 0000000000000014 CR3: 000000007051b000 CR4: 00000000000007f0
[   44.417020] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[   44.417020] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[   44.417020] Process rpc.nfsd (pid: 810, threadinfo ffff880071856000, task ffff880071088000)
[   44.417020] Stack:
[   44.417020]  ffff880070581008 ffff880070581008 ffff880071857ec8 ffffffffa02f5b9f
[   44.417020]  ffff880071857f50 00007fa3fffffffb ffff880070581009 ffff880071857e6f
[   44.417020]  0034fffffffffff4 0000000000000002 ffff880071857e88 ffffffff81129a36
[   44.417020] Call Trace:
[   44.417020]  [<ffffffffa02f5b9f>] write_ports+0x2cf/0x3e0 [nfsd]
[   44.417020]  [<ffffffff81129a36>] ? get_zeroed_page+0x16/0x20
[   44.417020]  [<ffffffff811aae95>] ? simple_transaction_get+0xc5/0xe0
[   44.417020]  [<ffffffffa02f58d0>] ? write_gracetime+0x60/0x60 [nfsd]
[   44.417020]  [<ffffffffa02f5047>] nfsctl_transaction_write+0x57/0x90 [nfsd]
[   44.417020]  [<ffffffff811881bc>] vfs_write+0xac/0x180
[   44.417020]  [<ffffffff811884ea>] sys_write+0x4a/0x90
[   44.417020]  [<ffffffff81614ae9>] system_call_fastpath+0x16/0x1b
[   44.417020] Code: 48 41 e1 eb b9 e8 23 a1 e6 e0 0f 1f 00 55 48 89 e5 53 48 83 ec 08 66 66 66 66 90 f6 05 68 1b 02 00 02 48 89 fb 0f 85 f7 00 00 00 <8b> 43 14 85 c0 0f 84 d6 00 00 00 83 e8 01 85 c0 89 43 14 0f 85 
[   44.417020] RIP  [<ffffffffa01ee1ae>] svc_destroy+0x1e/0x140 [sunrpc]
[   44.417020]  RSP <ffff880071857e28>
[   44.417020] CR2: 0000000000000014
[   44.441877] ---[ end trace c0df184a451cf666 ]---




Version-Release number of selected component (if applicable):
kernel-3.5.3-1.fc17.x86_64

How reproducible:
Once

Steps to Reproduce:
1. bootup
2.
3.
  
Actual results:
BUG

Expected results:
no BUG

Additional info:

Have these in /etc/rc.d/rc.local, since other attempts at having those packages around but not switched on failed (see other bugs about systemd):

systemctl --no-reload disable var-lib-nfs-rpc_pipefs.mount
systemctl --no-reload stop var-lib-nfs-rpc_pipefs.mount
systemctl --no-reload disable var-lib-nfs-rpc_pipefs.mount
systemctl --no-reload stop rpcbind.socket
systemctl --no-reload stop rpcbind.service 
systemctl --no-reload disable rpcbind.service  
systemctl --no-reload disable rpcbind.socket

This might be relevant.
Comment 1 Jaroslav Sykora 2012-09-19 02:50:20 EDT
related: bug 848867
Comment 2 Jeff Layton 2012-12-05 08:36:03 EST
*** Bug 863764 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Layton 2012-12-05 08:38:34 EST

*** This bug has been marked as a duplicate of bug 848867 ***

Note You need to log in before you can comment on or make changes to this bug.