Bug 858542 - Cherokee 1.2.101 RPMs should not be built with trace/backtrace support for performance
Cherokee 1.2.101 RPMs should not be built with trace/backtrace support for pe...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: cherokee (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Lisý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 02:10 EDT by sk.random2
Modified: 2013-06-02 23:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: cherokee-1.2.103-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 746532
Environment:
Last Closed: 2013-06-02 17:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sk.random2 2012-09-19 02:10:26 EDT
Description of problem:

As mentioned at http://www.cherokee-project.com/doc/dev_debug.html Cherokee shouldn't be compiled with trace or backtrace support for improved performance.

However, this is what the RPMs are being built with as per http://pkgs.fedoraproject.org/cgit/cherokee.git/tree/cherokee.spec#n96

Version-Release number of selected component (if applicable):

All RPMs.

How reproducible:

N/A

Additional info:

N/A
Comment 1 sk.random2 2012-09-20 21:22:41 EDT
Also, looks like the `shortversion` define regex isn't working correctly in cherokee.spec. (shortversion ends up being the same as the input; unchanged)

Perhaps something like this (appears to work in testing):

%define         shortversion   %(echo %{version} | sed -r 's/\.[0-9]+$//g')
Comment 2 Fedora Update System 2013-05-17 05:22:51 EDT
cherokee-1.2.103-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/cherokee-1.2.103-1.el6
Comment 3 Fedora Update System 2013-05-17 05:32:12 EDT
cherokee-1.2.103-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cherokee-1.2.103-1.fc17
Comment 4 Fedora Update System 2013-05-17 05:43:02 EDT
cherokee-1.2.103-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/cherokee-1.2.103-1.fc18
Comment 5 Fedora Update System 2013-05-17 05:48:43 EDT
cherokee-1.2.103-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cherokee-1.2.103-1.fc19
Comment 6 Fedora Update System 2013-05-17 18:16:33 EDT
Package cherokee-1.2.103-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing cherokee-1.2.103-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-5828/cherokee-1.2.103-1.el6
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-02 17:35:52 EDT
cherokee-1.2.103-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-06-02 22:58:30 EDT
cherokee-1.2.103-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-06-02 23:07:05 EDT
cherokee-1.2.103-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-06-02 23:46:26 EDT
cherokee-1.2.103-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.