Bug 85858 - Savage driver does very wierd
Savage driver does very wierd
Status: CLOSED DUPLICATE of bug 80346
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-09 12:08 EST by Philip Van Hoof
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Van Hoof 2003-03-09 12:08:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203

Description of problem:
On my IBM T20 thinkpad laptop (which has a Savage IX I think) the first time I
booted Phoebe everything worked perfectly! The second time I booted I saw very
wierd colors and stuff that should have been removed from the memory of the
gfx-card (like the bootup logo of the laptop). I fixed this by visiting the
official website of the savage driver and replacing it with the one that is
being shipping with RedHat 8.0.94. I have tried to fix the problem by using
redhat-config-xfree86. This tool, however, tried to set the driver to "vesa" in
800x600 which results in a VERY ugly resolution for this laptop. I have tried
every possible depth and resolution with the savage driver.. all gave the same
problem. I tried turning of the "Expand to full screen" in the BIOS of the
laptop and tried switching something about PCI and AGP.. still I got the same
results. I booted Windows to test if the card was broken but Windows displayed
the graphics correctly.. and then.. I decided to try to overwrite the savage
driver shipped with RedHat 8.0.94 with the official one on the website of the
driver.. I also replaced the XF86Config file with one that was available on a
website about my laptop. This works BUT I sometimes saw the
default-X-mouse-cursor AND the new RedHat 8.0.94 cursor at the same. I turned of
a option about HWCursor or something like that in the XF86Config file and the
problem dissapeared..



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
have described everything in the descriptionfield

    

Actual Results:  Wierd colors; I can see the stuff that was visible during the
booting of the laptop (the IBM-logo and stuff like that). The mousecursor is
visible but then like a brush (so it keeps painting the mousecursor and does not
remove the old one). Some parts of the desktop becomes visible (like icons and
text) but then dissapears..

Sort : the savage driver is very broken :)


Expected Results:  The same result as the default savage driver with HWCursor
set to off.

Additional info:
Comment 1 Mike A. Harris 2003-03-12 10:29:54 EST

*** This bug has been marked as a duplicate of 80346 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.