Bug 858622 - [PATCH] maven-scm cvs dependencies are mo more satisfied
[PATCH] maven-scm cvs dependencies are mo more satisfied
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: maven-doap-plugin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Radej
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 05:00 EDT by Igor Vlasenko
Modified: 2012-12-13 08:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 08:46:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.36 KB, patch)
2012-09-19 05:00 EDT, Igor Vlasenko
no flags Details | Diff

  None (edit)
Description Igor Vlasenko 2012-09-19 05:00:26 EDT
Created attachment 614279 [details]
proposed patch

Description of problem:
maven-scm dropped its cvs classes maven-doap-plugin depended on.
Apply proposed patch to build maven-doap-plugin without broken dependencies on cvs.

--- maven-doap-plugin-1.1/pom.xml~	2012-09-19 08:44:24.499951764 +0000
+++ maven-doap-plugin-1.1/pom.xml	2012-09-19 08:45:52.193690381 +0000
@@ -93,21 +93,6 @@
       <artifactId>maven-scm-provider-svnexe</artifactId>
       <version>${scmVersion}</version>
     </dependency>
-    <dependency>
-      <groupId>org.apache.maven.scm</groupId>
-      <artifactId>maven-scm-provider-cvs-commons</artifactId>
-      <version>${scmVersion}</version>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.maven.scm</groupId>
-      <artifactId>maven-scm-provider-cvsexe</artifactId>
-      <version>${scmVersion}</version>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.maven.scm</groupId>
-      <artifactId>maven-scm-provider-cvsjava</artifactId>
-      <version>${scmVersion}</version>
-    </dependency>
 
     <!-- misc -->
     <dependency>
--- maven-doap-plugin-1.1/src/main/java/org/apache/maven/plugin/doap/DoapMojo.java~	2011-01-11 13:28:29.000000000 +0000
+++ maven-doap-plugin-1.1/src/main/java/org/apache/maven/plugin/doap/DoapMojo.java	2012-09-19 08:51:50.768443714 +0000
@@ -65,7 +65,6 @@
 import org.apache.maven.project.ProjectBuildingException;
 import org.apache.maven.scm.manager.NoSuchScmProviderException;
 import org.apache.maven.scm.manager.ScmManager;
-import org.apache.maven.scm.provider.cvslib.repository.CvsScmProviderRepository;
 import org.apache.maven.scm.provider.svn.repository.SvnScmProviderRepository;
 import org.apache.maven.scm.repository.ScmRepository;
 import org.apache.maven.scm.repository.ScmRepositoryException;
@@ -1653,16 +1652,7 @@
 
         DoapUtil.writeStartElement( writer, doapOptions.getXmlnsPrefix(), "repository" );
 
-        if ( isScmSystem( repository, "cvs" ) )
-        {
-            DoapUtil.writeStartElement( writer, doapOptions.getXmlnsPrefix(), "CVSRepository" );
-
-            CvsScmProviderRepository cvsRepo = (CvsScmProviderRepository) repository.getProviderRepository();
-
-            DoapUtil.writeElement( writer, doapOptions.getXmlnsPrefix(), "anon-root", cvsRepo.getCvsRoot() );
-            DoapUtil.writeElement( writer, doapOptions.getXmlnsPrefix(), "module", cvsRepo.getModule() );
-        }
-        else if ( isScmSystem( repository, "svn" ) )
+        if ( isScmSystem( repository, "svn" ) )
         {
             DoapUtil.writeStartElement( writer, doapOptions.getXmlnsPrefix(), "SVNRepository" );
Comment 1 Tomas Radej 2012-11-29 09:12:09 EST
I am a co-maintainer of the package, and will have a look at this.
Comment 2 Tomas Radej 2012-12-13 08:46:53 EST
Hi, maven-doap-plugin is not required by anything any longer, so because it doesn't build for other reasons (there is a typed collection conversion inadmissible in Java 1.7), I am retiring the package.

Thank you for your contribution, but I'm closing this bug as wontfix.

Note You need to log in before you can comment on or make changes to this bug.