Bug 85864 - sendmail fails to deliver locally submitted email
sendmail fails to deliver locally submitted email
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-03-09 14:33 EST by Gerald Teschl
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-03-09 15:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2003-03-09 14:33:49 EST
Description of problem:
I noted that emails sent via squirrelmail to local users get
lost. So I looked at the problem more closely and it looks
like sendmail fails to deliver any locally submitted email
to local users.

Email from outside are delivered just fine.

How reproducible:

Steps to Reproduce:
I tried to send an email to a local user using
a) telnet localhost 25
b) mail
The mail is accepted by sendmail and corresponding log entries are written:

Mar  9 20:24:18 keen sendmail[10823]: h29JOH3I010823: from=root, size=30,
class=0, nrcpts=1, msgid=<200303091924.h29JOH3I010823@keen.esi.ac.at>,
Mar  9 20:24:18 keen sendmail[10826]: h29JOH3I010823: to=gerald, ctladdr=root
(0/0), delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30026, dsn=2.0.0,

However, the mail never shows up in the mailbox of the user!? Moreover,
the mailq is empty, so it is not hanging somewhere.
Comment 1 Gerald Teschl 2003-03-09 15:03:59 EST
This strange. I just did

rpm -e --nodeps sendmail
rm -rf /etc/mail
rpm -i sendmail-8.12.8-1.80.i386.rpm

copied my config files back and now it works just fine!?
I don't get it....

Note You need to log in before you can comment on or make changes to this bug.