Bug 858676 - Global uncaught exception with 'New' group creation from 'All groups'
Global uncaught exception with 'New' group creation from 'All groups'
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Resource Grouping (Show other bugs)
JON 3.1.1
x86_64 Linux
high Severity urgent
: ---
: JON 3.1.2
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 858533
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 08:03 EDT by Jirka Kremser
Modified: 2013-09-11 07:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 858533
Environment:
Last Closed: 2013-09-11 07:03:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jirka Kremser 2012-09-19 08:03:33 EDT
+++ This bug was initially created as a clone of Bug #858533 +++

Created attachment 614191 [details]
Screen shot

Description of problem:
Throws 'Global uncaught exception' while creating new group from All groups.

Version-Release number of selected component (if applicable):
RHQ 
Version: 4.5.0-SNAPSHOT
Build Number: a493f41
GWT Version: 2.4.0
SmartGWT Version: 3.0

How reproducible:
100%

Steps to Reproduce:
1.Login to RHQ GUI
2.Navigate to 'Inventory-->All Groups'
3.Click on 'New', throws Exception
  
Actual results:
Throws Exception. Root Cause: "(TypeError): Cannot read property 'jsObj' of null"

Expected results:
Able to create new groups without any error (or) exception.

Additional info: Screen shot and client error logs are attached. There is no exception on server side.

--- Additional comment from jkandasa@redhat.com on 2012-09-18 23:27:50 EDT ---

Created attachment 614192 [details]
ClientSideErrorLog (browser)

--- Additional comment from jkandasa@redhat.com on 2012-09-18 23:29:24 EDT ---

Browser: Firefox ESR 10.0.6
Issue reported by Overnight GUI automation job.

--- Additional comment from jkremser@redhat.com on 2012-09-19 07:03:08 EDT ---

looks like regression from bug 856599, i'll take it

--- Additional comment from jkremser@redhat.com on 2012-09-19 07:33:45 EDT ---

fixed in master

http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=9f17583

time:    Wed Sep 19 13:29:01 2012 +0200
commit:  9f1758393926e3a980b7148938aa358430762053
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 858533 - Global uncaught exception with 'New' group creation from 'All groups'] NPE was thrown, it was regression of b54ce46
Comment 1 Jirka Kremser 2012-09-19 08:06:03 EDT
has been fixed in master by 9f17583 and it needs to be cherry-picked once the release branch is ready for accepting the 3.1.2 commits
Comment 2 Jirka Kremser 2012-11-02 11:16:28 EDT
http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=f12d439b2

branch:  release/jon3.1.x
time:    Fri Nov 2 15:48:43 2012 +0100
commit:  f12d439b25ae9d3b96c525d25ede3d9da40a2b4f
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 858676 - Global uncaught exception with 'New' group creation from 'All groups'] NPE was thrown, it was regression of b54ce46. (cherry picked from commit 9f1758393926e3a980b7148938aa358430762053)

changing status to MODIFIED
Comment 3 Simeon Pinder 2012-11-15 00:04:38 EST
Moving this to ON_QA as available for testing in https://brewweb.devel.redhat.com//buildinfo?buildID=243389.
Comment 4 Filip Brychta 2012-11-20 04:37:54 EST
Verified on 3.1.2.ER1

Note You need to log in before you can comment on or make changes to this bug.