Bug 85868 - rpm --rebuilddb db4 error(11) issue after installing phoebe
rpm --rebuilddb db4 error(11) issue after installing phoebe
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
phoebe
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-09 17:38 EST by Amoor Avakian
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-10 11:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amoor Avakian 2003-03-09 17:38:15 EST
Description of problem:

I had RH 8, then i upgraded to Phoebe, the rpm database started to give
problems, i had to follow the instructions on this website :
http://www.rpm.org/hintskinks/repairdb/ but that did not work as when i ran "rpm
--rebuilddb" command i got this error :

error: db4 error(11) from dbenv->open: Resource temporarily unavailable

The same error is thrown by Ximian Red-Carpet AFTER the upgrade to Phoebe,
before it worked fine.  Thanks.
Comment 1 Jeff Johnson 2003-03-10 11:17:32 EST
rpm-4.2 uses posix mutexes for locking, so you need to
remove the database environment
    rm -f /var/lib/rpm/__db*

Red Carpet uses librpm404, which does not use posix mutexes,
so you are going to have interoperability problems until
Red Carpet starts to use rpm-4.1 or later.

Note You need to log in before you can comment on or make changes to this bug.