This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 858689 - spacewalk-setup-jabberd would incorrectly setup ipv6 although system has no ipv6 addresses configured
spacewalk-setup-jabberd would incorrectly setup ipv6 although system has no i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Jiří Mikulka
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-09-19 08:31 EDT by Milan Zazrivec
Modified: 2014-10-06 09:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:57:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2012-09-19 08:31:53 EDT
Description of problem:
spacewalk-setup-jabberd in stock Satellite 5.5 would incorrectly
configure jabberd to use IPv6 addresses although the system has
no IPv6 addresses configured.

spacewalk-setup-jabberd tries to decide whether or not to configure
jabberd for IPv6 based on existence of the following file:

    /proc/net/if_inet6

It is possible to configure system to contain the file above,
but not to have any IPv6 connectivity.

Version-Release number of selected component (if applicable):
spacewalk-setup-jabberd-1.7.0-2

How reproducible:
Always.

Steps to Reproduce:
1. RHEL-5 system, standard installation
2. Put the following into /etc/sysctl.conf:

net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.all.disable_ipv6 = 1

and reboot.

3. Install Satellite 5.5
  
Actual results:
* /proc/net/if_inet6 exists, but is empty.
* jabberd is configured with IPv6 addresses
* jabberd services (and osa-dispatcher by transition) fail to start

Expected results:
* /proc/net/if_inet6 exists, but is empty.
* jabberd is configured with IPv4 addresses
* jabberd services (and osa-dispatcher by transition) start correctly.


Additional info:
Upstream (Spacewalk) bug report for the same problem:

    https://bugzilla.redhat.com/show_bug.cgi?id=857284
Comment 1 neudorfer.wolfgang 2012-10-10 05:26:50 EDT
I can confirm this behaviour.
Comment 3 Milan Zazrivec 2013-01-02 12:56:06 EST
spacewalk.git master: 0ceb57ccd8719e7d999680ef0ccfcc7f67b1c580
Comment 5 Milan Zazrivec 2013-01-03 03:00:13 EST
spacewalk.git master: 1c3108f0929bd90748bd367fe5560801dc5cf842
Comment 8 Clifford Perry 2013-10-01 17:57:12 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.