Bug 85874 - gnome-terminal scrolling slow
gnome-terminal scrolling slow
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-terminal (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-09 21:16 EST by Oliver Aaltonen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-10 11:33:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Aaltonen 2003-03-09 21:16:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When running gnome-terminal with Phoebe, scrolling is much slower than when
using gnome-terminal under 8.0.

When I run:
ls /*
the output appears scrolls extremely slowly down the screen, takes a long time
to finish completely. When I run this on a RH8 system, it is much faster. Also,
if I run xterm with the same command, the ls command finishes in a second or
two, much faster than gnome-terminal.

The same bug appears when running anything that causes text to scroll down the
terminal, such as a cat command, etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open gnome-terminal (I've used command line as well as "New Terminal..."
2. Execute the command: ls /*
3. Watch the information slowly scroll down the terminal.
    

Actual Results:  Everything was listed correctly, just very slowly.

Expected Results:  Everything should have been listed in a couple seconds.

Additional info:

No error message.

System is a RH8 laptop upgraded to Phoebe
Comment 1 Warren Togami 2003-03-10 02:51:17 EST
CPU usage seems to be VERY high for the X process while gnome-terminal is
scrolling.  Xft?
Comment 2 Havoc Pennington 2003-03-10 11:33:21 EST
This was fixed, g-t can now do the ls faster than xterm.
Not sure if it's in rawhide. The package to upgrade would be vte 
not g-t. (And the package to assign this bug to if you ever reopened 
it would also be vte.)

Note You need to log in before you can comment on or make changes to this bug.