Bug 85874 - gnome-terminal scrolling slow
Summary: gnome-terminal scrolling slow
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-terminal
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-10 02:16 UTC by Oliver Aaltonen
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-10 16:33:21 UTC


Attachments (Terms of Use)

Description Oliver Aaltonen 2003-03-10 02:16:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When running gnome-terminal with Phoebe, scrolling is much slower than when
using gnome-terminal under 8.0.

When I run:
ls /*
the output appears scrolls extremely slowly down the screen, takes a long time
to finish completely. When I run this on a RH8 system, it is much faster. Also,
if I run xterm with the same command, the ls command finishes in a second or
two, much faster than gnome-terminal.

The same bug appears when running anything that causes text to scroll down the
terminal, such as a cat command, etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open gnome-terminal (I've used command line as well as "New Terminal..."
2. Execute the command: ls /*
3. Watch the information slowly scroll down the terminal.
    

Actual Results:  Everything was listed correctly, just very slowly.

Expected Results:  Everything should have been listed in a couple seconds.

Additional info:

No error message.

System is a RH8 laptop upgraded to Phoebe

Comment 1 Warren Togami 2003-03-10 07:51:17 UTC
CPU usage seems to be VERY high for the X process while gnome-terminal is
scrolling.  Xft?


Comment 2 Havoc Pennington 2003-03-10 16:33:21 UTC
This was fixed, g-t can now do the ls faster than xterm.
Not sure if it's in rawhide. The package to upgrade would be vte 
not g-t. (And the package to assign this bug to if you ever reopened 
it would also be vte.)


Note You need to log in before you can comment on or make changes to this bug.